Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
1998
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 1998

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Single character in Italics. Ervin Doyle;

  • To: mathgroup at smc.vnet.net
  • Subject: [mg14683] Re: Single character in Italics. Ervin Doyle;
  • From: "P.J. Hinton" <paulh>
  • Date: Sun, 8 Nov 1998 21:15:42 -0500
  • Organization: "Wolfram Research, Inc."
  • References: <720t57$1uv@smc.vnet.net>
  • Sender: owner-wri-mathgroup at wolfram.com

On 7 Nov 1998, Ervin F. Doyle wrote:

> I recently purchased Mathematica 3.0.1. When I type a single character 
> like "a" it comes out in italics. However, when I type two or more 
> characters like "ad" or "abc" I get the characters in bold face. This 
> italic single character appears when I'm setting up equations like f 
> := ... or g = ....Is there a reason for this? Do I have to use 
> double characters  in my definitions etc. to avoid the italics when I 
> don't want them.

The behavior you describe will occur when the option SingleLetterItalics
has been set to True.  Some cell styles and format types have this
setting turned on in the Default style sheet.  This includes
InlineFormula, DisplayFormula, and any cell which uses TraditionalForm
as its default input format type.

This option is documented in _The Mathemaitca Book_ (Third Edition),
section 2.10.11.  If you have access to the online version of the book
in the help browser, evaluating the following expression in a notebook
will take you to the relevant material:

FrontEndExecute[FrontEnd`HelpBrowserLookup["MainBook", "2.10.11"]]

You can avoid the single letter italics problem by either doing one of
the following:

o setting the option SingleLetterItalics -> False for the cell that
you're working on

o importing a private copy of your choice of style sheet and editing the
style definition cell for the cell so that SingleLetterItalics is False

o choosing a different cell style that does not have this property set

o if you are using TraditionalForm as your default input format type,
switch to StandardForm

--
P.J. Hinton
Mathematica Programming Group           paulh at wolfram.com Wolfram
Research, Inc.                  http://www.wolfram.com/~paulh/
Disclaimer: Opinions expressed herein are those of the author alone.



  • Prev by Date: Re: Problems writing output-files
  • Next by Date: Re: algebra problem, need help fast!!!
  • Previous by thread: Re: Single character in Italics. Ervin Doyle;
  • Next by thread: Re: Single character in Italics. Ervin Doyle;