Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
1998
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 1998

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Linux: couldn't reach []{} with latin2 keyboard layout

  • To: mathgroup at smc.vnet.net
  • Subject: [mg14686] Re: Linux: couldn't reach []{} with latin2 keyboard layout
  • From: phbrf at t-online.de (Peter Breitfeld)
  • Date: Sun, 8 Nov 1998 21:15:44 -0500
  • Organization: das ist ein weites Feld ...
  • References: <719e77$la3@smc.vnet.net> <71jlbl$8nu@smc.vnet.net> <71q6ho$ijo@smc.vnet.net>
  • Sender: owner-wri-mathgroup at wolfram.com

Davor Cengija <dcengija at public.srce.hr_OBRISI_.tel.hr> schrieb:
> Peter Breitfeld wrote:
> > 
> > Davor Cengija <dcengija at public.srce.hr_OBRISI_.tel.hr> schrieb/wrote:
> > > I'm using Mathematica 3 on RH5.1 (2.0.35)
> > >
> > > Is there a way to make Mathematica to use latin2 keyboard layout?
> > 
> > I think you should edit the file KeyEventTranslations.tr located
>[snip] 
> Yes, I found that tip on Wolfram's web page. But, the problem is that
> Mathematica doesn't understand AltGr key. Wolfram's programmers know
> for this problem and trying to solve it.
> 
I think you should have something like 
add Mod2 = Mode_switch
in your .Xmodmap, to make the system know about AltGr

> I didn't edit that file you mentioned above, but i mapped the offended
> keys on unused keys on my win95 keyboard using xmodmap (much less  to
> edit, works system wide)
> 
> > 
> > Do this for all Keys you need.
> > I'm using Linux too, and I have to start Mathematica with the option
> > "-pureKeys" to make this work properly.
> > 
> 
> -pureKeys doesn't have any effect

If I ommit this option I can't neither reach the umlauts nor the {[]}\
characters

> 
> I have another problem: can't reach croatian language specific
> characters (such as S with litle v above, equivalent to Sch, etc). you
> can use german language specifics (such as Aumlaut, Oumlaut etc)?
> 
For the umlauts I have in my .Xmodmap eg
keycode 0x14 = ssharp
...

For your characters you first have to check if they can be displayed, eg
consult 
/usr/X11R6/lib/X11/locale/iso8859-2/Compose  This is a listing of all
the chars you can build using the compose-key, which has to be defined
as Multi_key in your .Xmodmap. There I found eg:
<Multi_key> <S> <less>                  : "\251"        Scaron


I use on my W95-Keybord the folling settings for the last row of the
keyboard:

keycode 0x25 =  Control_L
keycode 0x40 =  Alt_L           Meta_L keycode 0x74 =  Alt_L          
Meta_L keycode 0x41 =  space
keycode 0x71 =  Mode_switch
keycode 0x73 =  Mode_switch
keycode 0x75 =  Multi_key
keycode 0x6D =  Control_R

This results in the keybindings

Control, AltGR, Alt, Space, AltGR, Alt, Compose, Control

es gruesst
      Peter

-- 
=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=
  P e t e r  B r e i t f e l d              eMail: phbrf at t-online.de
  Kreuzgasse 4, 88348 Saulgau, Germany      PGP public key: 08548045
=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=


  • Prev by Date: Re: using Upset for defining positive real values (Re: Can I get ComplexExpand to really work?)
  • Next by Date: Re: Pb with finding a residue
  • Previous by thread: Re: Linux: couldn't reach []{} with latin2 keyboard layout
  • Next by thread: Re: Too Tiny Fonts! in fractions, summations, etc.