Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
1998
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 1998

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Mouse is always a hand with Linux.

  • To: mathgroup at smc.vnet.net
  • Subject: [mg14262] Re: Mouse is always a hand with Linux.
  • From: sb.nospam at stonesoft.com (Stonewall Ballard)
  • Date: Mon, 12 Oct 1998 13:51:44 -0400
  • Organization: StoneSoft, Inc.
  • References: <6vf3ll$dcs@smc.vnet.net>
  • Sender: owner-wri-mathgroup at wolfram.com

In article <6vf3ll$dcs at smc.vnet.net>, "Steven T. Hatton"
<hattons at cpkwebser5.ncr.disa.mil> wrote:

> I hope this is an easy question.  My mouse cursor always appears as a
> hand when it is placed over the input part of the window.  This renders
> the mouse useless in manipulating input.  I am using S.u.S.E. Linux
> 5.3, and the KDE desktop.  The mouse has worked fine in all other apps.
> Does anybody know what is wrong?
> 
> TIA,
> 
> Steve
> 

Do you have your Num Lock key on? I asked Wolfram TS this question
earlier this week. They said:

> Check to see what the Mod2 keysym is mapped to.  I suspect that it is
> mapped to your Num Lock key.  You can verify this by clicking on the
> following menu sequence on the X front end's window:
> 
>         Help    ->      X Environment Information
> 
> This will bring up a dialog box.  Find the subsection called "Keyboard
> Attributes.  The Mod2 keysym will be the second item down.
> 
> If the Mod2 keysym is mapped to Num Lock, hit the Num Lock key to turn
> it off.  When you start moving the mouse pointer within the X front
> end's window, the pointer cursor will revert back to the I-beam, and
> all will be well.
> 
> Depressing Mod2 turns on an undoucmented feature of the X front end --
> global selection.  When global selection is activated, the mouse
> pointer will change from an I-beam to a hand.  You cannot place a text
> edit cursor within a cell in this mode, but if you select a cell of a
> given style, then all cells of that style will be selected.  
> 
> Simply deselecting Num_Lock will correct this. A more definite fix is to 
> remap Mod2.  This is done by using the command xmodmap.  More information 
> about setting xmodmap is located in your system's "man" pages.

  - Stoney

-- 
Stonewall Ballard                    StoneSoft, Inc.
sb.nospam at stonesoft.com    http://www.stonesoft.com/ .



  • Prev by Date: Asymptotic expansions
  • Next by Date: Re: Labeling graphs
  • Previous by thread: Re: Asymptotic expansions
  • Next by thread: Re: Mouse is always a hand with Linux.