Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
1999
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 1999

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: MathLink performance

  • To: mathgroup at smc.vnet.net
  • Subject: [mg20237] Re: MathLink performance
  • From: Jens-Peer Kuska <kuska at informatik.uni-leipzig.de>
  • Date: Fri, 8 Oct 1999 18:30:15 -0400
  • Organization: Universitaet Leipzig
  • References: <7tgs01$smo@smc.vnet.net>
  • Sender: owner-wri-mathgroup at wolfram.com

Hi,

this is strange and I assume a bug in your C code. I have several
MathLink programs for images and I can tell you that this effect 
has nothing to do with Mathematica or MathLink. Can you send me
the C-source ? I will have a look on it to see whats wrong.

Regards
  Jens


"Roberto Abraham at IoA, Cambridge" wrote:
> 
> Hi -- I'm trying to improve the performance of my MathLink C code (which
> reads an image file into Mathematica). I've noticed that the first time I
> call my external function to access my image data it runs much more
> quickly than when I call it subsequently (by about a factor of 10). Does
> anyone have an explanation for this behaviour? I've tried contacting WRI
> technical support about this issue but have not really gotten an answer.
> 
> Regards,
> 
> Bob Abraham


  • Prev by Date: Re: simplifying expressions
  • Next by Date: Re: Problem Printing Rational Numbers
  • Previous by thread: MathLink performance
  • Next by thread: Why Doesn't N[Pi,i] Give i Digits For Small i, Mathematica 4,on NT