Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
1999
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 1999

[Date Index] [Thread Index] [Author Index]

Search the Archive

Font problems running remotely

  • To: mathgroup at smc.vnet.net
  • Subject: [mg20372] Font problems running remotely
  • From: "William F. Campbell" <valentin at wam.umd.edu>
  • Date: Sun, 17 Oct 1999 02:45:44 -0400
  • Organization: UMD Dept. of Meteorology
  • Sender: owner-wri-mathgroup at wolfram.com

I'm having a problem with remotely using Mathematica at school. I am
running Win95 on my PC at home, and using Micro XWindows XWin32.exe
XWindows emulator.  Mathematica is installed at school (DEC Alphas, under
Digital Unix). When I use the workstations at school, Mathematica works fine.
Back when they had Mathematica 2.2, I could use Mathematica from home with Micro
XWindows,
no problems. Now that they have version 3 at school, I'm having a
fonts problem. The error message I get is:

xset: bad font path element (#35), possible causes are:
 Directory does not exist or has wrong permissions
 Directory missing fonts.dir
 Incorrect font server address or syntax

Mathematica comes up, but has substituted Courier for Math1. Is this a problem
with my home system (on which the fonts do exist, as I have Mathematica 3 for
students), Micro XWindows, or the UNIX install at school? The
sys-admin has been less than helpful.&nbsp; Any help would be
appreciated.

BTW, in my .cshrc file, the following entry exists:

set MANPATH=/local/man:/usr/share/local/man:/usr/share/man
 set path = ( $HOME/bin $HOME/com /usr/ucb /usr/bin /bin /usr/etc /etc
\
 . /usr/bin/X11 /usr/sbin /usr/local/bin /local/bin /usr/dt/bin \
 /usr/local/src/math /usr/local/src/math/Bin
/usr/local/src/math/Install )

and

 xset fp+ /misc/local/mathematica/SystemFiles/Fonts/Type1

The /misc/local/mathematica.../Type1 directory exists (on the UNIX
box), and has the fonts.dir
file as well as a bunch of other stuff in it. The error messages cited
above are printed when I source .cshrc, as well as when I attempt to
run Mathematica. This command supposedly tells the xserver to append the above
path to the font path (here is the man excerpt)

+fp or fp+
 The +fp and fp+ options prepend and append elements to the current
font
 path, respectively. They must be followed by a comma-separated list
of entries.
The entire font path must be valid; if any element is invalid, the
path is rejected.

The /usr/local/src directory exists, but there is no math directory
there.
I tried eliminating the directories that don't exist from the path,
using +fp instead of fp+, and copying all of the contents of
/misc/local/mathematica/SystemFiles/Fonts/Type1
to a new directory called Type1 in my home directory, with all the
permissions
set, and fonts.dir existing, and I still go the same error when I
tried
to xset +fp Type1 (repeated below for convenience).

xset: bad font path element (#35), possible causes are:
Directory does not exist or has wrong permissions
Directory missing fonts.dir
Incorrect font server address or syntax

When I type xset q, I am informed that the font path is
Font Path:
  c:/inet20/xwin32/lib/fonts/misc,c:/inet20/xwin32/lib/fonts/75dpi

This leads me to believe that the fonts must exist on the Windows box,
and that I need to tell XWin32 where they are.  So I put them in the
c:/inet20/xwin32/lib/fonts/ directory.  But they don't end in .fon,
like the other fonts, or .bdf or .pcf, which the XWin32 documentation
seems to want.  They end in .pfa (same as on the UNIX box), or .ttf
(True Type fonts), and I get an error when I try to add them to the
fontpath and run XWin32 ("Failed to add to font path, or some such")

Sorry this is so long, but it's very frustrating.  Any help would be
greatly appreciated

Bill Campbell



  • Prev by Date: Mathematica 3.0 - 4.0 discrepancies.
  • Next by Date: Re: plotting function w/ Im and Re vals
  • Previous by thread: RE: Mathematica 3.0 - 4.0 discrepancies.
  • Next by thread: Re: Font problems running remotely