Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2000
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2000

[Date Index] [Thread Index] [Author Index]

Search the Archive

JLink

  • To: mathgroup at smc.vnet.net
  • Subject: [mg23676] JLink
  • From: Megan Roberts <megan at tarms.com>
  • Date: Mon, 29 May 2000 12:24:05 -0400 (EDT)
  • Organization: TARMS
  • Sender: owner-wri-mathgroup at wolfram.com

I am using Mathematica 4 installed on a Windows NT 4 platform. I
downloaded J/Link from your website and have installed it. I have
created a jar with the relevant class files and put this in my system
classpath. One of my method names, discount_rate, caused problems
because of the under score. I then changed this method name,
re-created
a new jar and started Mathematica again. The problem is when I type
the
Methods[myObject] command I still get discount_rate (even though this
method name is not in any of the class files in the jar).

I have tried the following things to remedy this:
* I recreated the jar, giving it a new name. I then referred to this
new
jar in my classpath and deleted the reference to the old one. I
restarted Mathematica and still got discount_rate() returned in my
method list.
* I shutdown (and restarted!) my computer, but still the problem
existed.
*I opened a new Notebook and typed the commands from scratch, but to
no
avail.

I would like to know how Mathematica is referencing the old method
name
even though it doesn't exist anymore.

Thanks in advance for you help,

Megan





  • Prev by Date: Re: Newbie Q: Referencing Auto-number Cells
  • Next by Date: Re: programming DeleteRepetitions
  • Previous by thread: [Q] accuracy control in eq. solving?
  • Next by thread: Re: JLink