Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2001
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2001

[Date Index] [Thread Index] [Author Index]

Search the Archive

J/Link

  • To: mathgroup at smc.vnet.net
  • Subject: [mg27319] J/Link
  • From: Rainer Gruber <rainer.gruber at students.uni-linz.ac.at>
  • Date: Wed, 21 Feb 2001 03:16:48 -0500 (EST)
  • Organization: Johannes Kepler Universitaet Linz
  • Sender: owner-wri-mathgroup at wolfram.com

Hi there,

I have a little problem using J/Link.
I have two computers with Mathematica 4.0.1.0 running under Windows 98. On both devices there is the same Java version installed. On one computer J/Link works fine, on the the other one it does not run at all!

Though its possible to start Java with InstallJava[] I can't create a Java object with JavaNew[] or LoadClass[] but I always get an error message like
LoadClass::"fail" :  Java failed to load class ...

I have tried all possibilities for PATH and CLASSPATH but I had no success!

The only idea I have: On the computer where J/Link doesn't work I've another directory structure than the usual one (C:\Mathematica4\... instead of C:\Programme\Wolfram Research\Mathematica\4.0\... or so).

Is this an obstacle problem for J/Link?

Thanks in advance

Rainer Gruber
JOHANNES KEPLER UNIVERSITY LINZ
Institute of Experimental Physics
Atomic Physics and Surface Science
(rainer.gruber at gmx.at)


  • Prev by Date: Re: simple Problem: D[ ]
  • Next by Date: Re: page breaks ?
  • Previous by thread: Re: SetDelayed problems with matrix operation
  • Next by thread: Re: J/Link