Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2003
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2003

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Just trying to import an image

  • To: mathgroup at smc.vnet.net
  • Subject: [mg44552] Re: Just trying to import an image
  • From: Bob Harris <nitlion at mindspring.com>
  • Date: Fri, 14 Nov 2003 01:58:44 -0500 (EST)
  • References: <bonnfg$h8i$1@smc.vnet.net> <bopcu5$opr$1@smc.vnet.net> <200311121301.IAA12554@smc.vnet.net> <bovev3$l04$1@smc.vnet.net>
  • Sender: owner-wri-mathgroup at wolfram.com

Yas wrote:
> Maybe put the path to the conversion executables to your path via
>
> AppendTo[$Path, 
> "Path_To_Conversion_Executables_in_proper_syntax_for_your_platform"]

Thanks for the idea.  Have now tried that, but get the same error message.
Am patterning my path syntax after what is already in the $path variable.
Pretty sure I specified the right path, but in case not, I moved the file
(gif.exe) to top level of disk and tried specifying that.  Same result.

> I am surprised that the conversion filters can't be found.

Well, that makes two of us!  Am wondering if there is a customer service
site I can post this issue for someone at wolfram.

I suppose I can write a tiny app in C that will to convert my .gif image
into something else mathematica could read without a converter.  Moot point
now though.  The project was due today.  I ended up doing it in another system on
campus.  One advantage I had hoped for, using mathematica, was that I have
it at home and thus can accomplish something even when the school labs are
closed from midnight to 8).  Plus I'm more familiar with Mathematica than
another system, so once I got past the image load problem I was expecting to make
faster progress.

Thanks, in any case,
Bob H

> From: Yasvir Tesiram <yat at omrf.ouhsc.edu>
To: mathgroup at smc.vnet.net
> Date: Wed, 12 Nov 2003 12:43:33 -0600
> To: mathgroup at smc.vnet.net
> Cc: Bob Harris <nitlion at mindspring.com>
> Subject: [mg44552] Re: [mg44497] Re: Just trying to import an image
> 
> Maybe put the path to the conversion executables to your path via
> 
> AppendTo[$Path, 
> "Path_To_Conversion_Executables_in_proper_syntax_for_your_platform"]
> 
> If this works, you can make the change permanent in Preferences. I am
> surprised that the conversion filters can't be found.
> 
> Yas
> 
> 
> On Nov 12, 2003, at 7:01 AM, Bob Harris wrote:
> 
>> Howdy, Steven,
>> 
>> Thanks for the idea.  But it seems that the problem is that Mathematica
>> can't find the converter.  I've already figured out how to make it
>> find the
>> image.
>> 
>> Bob H
>> 
>>> From: "Steven Shippee" <slshippee at comcast.net>
To: mathgroup at smc.vnet.net
>> To: mathgroup at smc.vnet.net
>>> Organization: Comcast Online
>>> Newsgroups: comp.soft-sys.math.mathematica
>>> Date: Tue, 11 Nov 2003 01:10:29 +0000 (UTC)
>>> Subject: [mg44552] [mg44497] Re: Just trying to import an image
>>> 
>>> To make it easy to debug, try putting the file (the "image") in a root
>>> directory somewhere (of your "c" drive or your "d" drive), and also
>>> ensure
>>> it has no spaces in the file name, for example, use something like
>>> c:\practice.jpg or c:\practice.bmp.
>>> 
>>> Then you could run the command
>>> 
>>> myimage=Import["c:\practice.jpg"];
>>> 
>>> and manipulate myimage from there.
>>> 
>>> Steven
>>> 
>>> shippee at jcs.mil
>>> 
>>> 
>>> 
>>> "Bob Harris" <nitlion at mindspring.com> wrote in message
>>> news:bonnfg$h8i$1 at smc.vnet.net...
>>>> Howdy,
>>>> 
>>>> Have an assignment in an computer vision class I'm taking.  Thought
>>>> I'd
>>> try
>>>> fiddling around with it in Mathematica.  Have run into the second or
>>>> third
>>>> brick wall, just trying to bring an image into Mathematica.  Am in
>>>> need of
>>>> help.
>>>> 
>>>> For starters, I found Import[] in the big book and tried it:
>>>> Import ["vl100.gif"]
>>>> The file vl100.gif is in the same directory as the mathematica
>>>> notebook
>>> that
>>>> I launched.  But that seems not to be one of the places mathematica
>>>> looks.
>>>> So I just got a file not found error.  So be it.
>>>> 
>>>> I figured there must be a way to convince mathematica to look for
>>>> the file
>>>> where e file is.  After stumbling around for a while in the book and
>>>> in
>>> the
>>>> help browser, I finally found the SetDirectory command.  So looking
>>>> at the
>>>> format of file paths in $Path, I did
>>>> SetDirectory["Kablooie:ClassesS:VisionS:Project4S"]
>>>> which is the path to the directory containing the file.
>>>> 
>>>> So then I tried
>>>> Import ["vl100.gif"]
>>>> again, and I get
>>>> Experimental`RegisterConverter::noexe: Could not find the
>>>> executable GIF.exe in any of { <<65>>, <<74>>, <<83>>, GIF.exe}.
>>>> 
>>>> Now, I'm running this using mathematica 4.0.1.0 for the Mac on a
>>>> PowerMac
>>> G3
>>>> running OS 9.0.4.  Yes, I know I haven't upgraded in a while, but it
>>>> sure
>>>> seems like what I'm trying to do is supposed to work on my
>>>> configuration.
>>>> 
>>>> The error message suggests that it doesn't have the executable code
>>>> to
>>>> handle gif images.  I tried .pgm format and got the same result.
>>>> Since
>>> both
>>>> are listed in the big book I figured it's pointless to try other
>>>> formats.
>>>> Those two should've worked.
>>>> 
>>>> I did a search of my hard drive and I do find a gif.exe (and hdf.exe,
>>>> jpeg.exe, pnm.exe, and tiff.exe) in the folder
>>>> ... MathematicaS:SystemFiles:Converters:Binaries:PowerMac
>>>> So it seems like it's got 'em, and it's just not looking for them.
>>>> 
>>>> Can anyone point me toward a way to get this working?
>>>> 
>>>> Thanks for any help,
>>>> Bob H
>>>> 
>>> 
> 


  • Prev by Date: Re: Re: Fluid dynamics
  • Next by Date: I have put "==" in every equation I have in NDSolve, why it keeps telling me they are not equations
  • Previous by thread: Re: Re: Just trying to import an image
  • Next by thread: Re: Just trying to import an image