Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2004
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2004

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Integration of UnitStep has bugs!? help!

  • To: mathgroup at smc.vnet.net
  • Subject: [mg51595] Re: Integration of UnitStep has bugs!? help!
  • From: Karl_boehme_9 at msn.com (Klaus G)
  • Date: Wed, 27 Oct 2004 01:53:54 -0400 (EDT)
  • References: <clcnlr$q41$1@smc.vnet.net>
  • Sender: owner-wri-mathgroup at wolfram.com

"news" <symbio at s.dn.com> wrote in message news:<clcnlr$q41$1 at smc.vnet.net>...
> Can anyone explain why Integrate does not work propery with UnitStep 
> function?  When you integrate from -inf to inf you get one answer, but when 
> you split it to two sections (from -inf to 0, and then from 0 to +inf) you 
> get a different answer.  Which is correct?  And why is Mathematica version 5 
> has not fixed this problem yet?  See below.
> 
> In[1]:=
> \!\(\(x[t_] = \((3 Exp[\(\(-1\)\/2\) t] UnitStep[t])\) +
> DiracDelta[t + 3];\)\[IndentingNewLine]
> \(h[t_] = UnitStep[t] - UnitStep[t - 2];\)\[IndentingNewLine]
> \(eq1 =
> Integrate[
> [.................]

Please use ASCII code. I cannot read that.

Klaus G.


  • Prev by Date: Help with a calculation
  • Next by Date: Re: exporting vector graphics
  • Previous by thread: Integration of UnitStep has bugs!? help!
  • Next by thread: Re: Integration of UnitStep has bugs!? help!