Services & Resources / Wolfram Forums
MathGroup Archive
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2005

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Mathematica 5.1 JLink problem (solved)

  • To: mathgroup at
  • Subject: [mg53523] Re: [mg53505] Mathematica 5.1 JLink problem (solved)
  • From: "J. McKenzie Alexander" <jalex at>
  • Date: Sat, 15 Jan 2005 21:07:52 -0500 (EST)
  • References: <> <>
  • Sender: owner-wri-mathgroup at

Please ignore the question below. I forgot to update the versions of 
JLink.jar and libJLinkNativeLibrary.jnilib in my personal 
~/Library/Java/Extensions/ folder when updating to Mathematica 5.1


On 15 Jan 2005, at 06:44, J. McKenzie Alexander wrote:

> I've recently installed Mathematica 5.1 on a Mac OS X box (running
> Panther 10.3.7).  After copying the Mathematica bundle to
> /Applications/ as the Administrator, then switching back to my ordinary
> user account, I found that JLink could not be started.  Evaluating
> (from a fresh kernel session)
> 	Needs["JLink`"];
> 	InstallJava[];
> Gives, as error messages,
> 	InstallJava::uifail:
> 	The separate Java user-interface link could not be established.
> 	InstallJava::fail:
> 	A link to the Java runtime could not be established.
> However, if I evaluate the above when logged in as Administrator, JLink
> starts just fine.  JLink under Mathematica 5.0 (which I still have
> installed as well) works just fine from my ordinary user account.
> Any guesses as to what might be wrong?
> Cheers,
> Jason
J. McKenzie Alexander
Department of Philosophy, Logic and Scientific Method
London School of Economics and Political Science
Houghton Street, London WC2A 2AE

  • Prev by Date: Re: cubic quaternion based surface
  • Next by Date: Re: Problem with DSolve
  • Previous by thread: Mathematica 5.1 JLink problem
  • Next by thread: The strange behaviour of NIntegrate