Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2005
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2005

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Can't assign value to symbols

  • To: mathgroup at smc.vnet.net
  • Subject: [mg58445] Re: Can't assign value to symbols
  • From: Bill Rowe <readnewsciv at earthlink.net>
  • Date: Sat, 2 Jul 2005 04:07:07 -0400 (EDT)
  • Sender: owner-wri-mathgroup at wolfram.com

On 7/1/05 at 2:02 AM, leenewm at umich.edu (Lee Newman) wrote:

>Situation:  I have a table that contains parameters and sets of
>values that I want to assign to the parameters for the purposes of
>running a simulation.
>- parameters = {{a,b,c},{1,2,3},{4,5,6},{7,8,9}}
>- want to assign values in a given row to the symbols listed in the 
>first row.
>- tried using:  MapThread[  #1 = #2 &, {parameters[[1]], parameters[[3]]} ]
>- fails with error  "Tag Slot in #1 is Protected"
>- tried adding Unprotect[#1] and a variety of other attemps, but can't 
>get it to work.

>Anyone know how might accomplish this?

Instead of

MapThread[#1 = #2&, {parameters[[1]], parameters[[3]]}]

use

MapThread[Set[#1,#2]&, {parameters[[1]], parameters[[3]]}]

I don't know why the second form works when the first form fails.
--
To reply via email subtract one hundred and four


  • Prev by Date: Re: Explicit solution to Root[]
  • Next by Date: Re: a question about the UnitStep function
  • Previous by thread: Re: Can't assign value to symbols
  • Next by thread: Re: Can't assign value to symbols