Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2005
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2005

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Did something change?

  • To: mathgroup at smc.vnet.net
  • Subject: [mg58130] Re: Did something change?
  • From: "Stefan Linnik" <sjl.news56 at tiscali.co.uk>
  • Date: Sun, 19 Jun 2005 03:43:40 -0400 (EDT)
  • References: <d90tjl$9bc$1@smc.vnet.net>
  • Sender: owner-wri-mathgroup at wolfram.com

To do direct assignments using = the list must first be initialised.

Also f[i] should be f[[i]]

Also as well f[[i, 1, 3]]= 7 works better than f[[i]][[1,3]]= 7

f=Array[0&,{10,8,8}];
Do[
  f[[i]]=IdentityMatrix[8];
  f[[i,1,3]]=7,
  {i,10}
  ]

Stefan Linnik
~~~~~~~~


"Ronald Bruck" <bruck at math.usc.edu> wrote in message 
news:d90tjl$9bc$1 at smc.vnet.net...
> Recently I created a list of several matrices, something like
>
>   Do[F[i] = IdentityMatrix[8]; F[i][[1,3]] = 7, {i,10}]
>
> and was surprised to get the message that F[i] wasn't a symbol.  I'm
> pretty sure code similar to that worked prior to Mathematica 5.  Did
> something change?
>
> I've also tried Symbolize[F[i]] in that loop, but it doesn't help;
> Mathematica refuses to access part [[1,3]] of F[i], claiming F[i] isn't
> a symbol.
>
> How are you supposed to set the individual values of a matrix if you
> can't do this?  This is an EXTREMELY unhelpful "feature".
>
> --Ron Bruck
> 



  • Prev by Date: Re: Did something change?
  • Next by Date: Re: Did something change?
  • Previous by thread: Re: Did something change?
  • Next by thread: Nested Commutators