Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2006
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2006

[Date Index] [Thread Index] [Author Index]

Search the Archive

AuthorTools "Make Contents" no makes contents?

  • To: mathgroup at smc.vnet.net
  • Subject: [mg68855] AuthorTools "Make Contents" no makes contents?
  • From: AES <siegman at stanford.edu>
  • Date: Mon, 21 Aug 2006 03:28:08 -0400 (EDT)
  • Organization: Stanford University
  • Sender: owner-wri-mathgroup at wolfram.com

The AuthorTools "Make Contents" palette in Mathematica 5.1 just doesn't 
seem to want to create or save a notebook TOC on a single-user Mac iBook 
G4 running OS 10.3.9.

I have a working (and correctly evaluating) notebook with 
Section/Subsection/Subsubsection headings in it.

With this notebook open, the AuthorTools palette opens fine from the 
File >> Palettes >> OpenAuthorsTools menu, and the MakeContents and 
other sub-palettes open fine from it . . . but MakeContents doesn't.

Any time I click on the Make Simple Contents button after doing some 
editing in the notebook involved, I get the dialog box saying the  
notebook must be saved to use Make Contents.   So, I do a Save and try 
the Make Simple Contents button again . . . but nothing visible happens, 
and no TOC (that I can find, anyway) seems to get created, or at least 
to appear in the Finder.

If I click inside any one cell, then click the Make Simple Contents 
button, the title bar of the active notebook flashes to "Running . . " 
for just a second (this doesn't happen above).  If I select one or 
multiple or all cells and click, this flash doesn't happen.

I can change various MakeContents options using the SelectedCellStyles 
or ContentsFileName buttons, and these changes stick.

If I open the NotebookDifferences subpalette and click the Notebooks... 
button, the dialog box that opens shows the notebook I'm working on as 
the first notebook.

But no TOC (that I can find, anyway) ever seems to get created, or at 
least appear in the Finder.

I've restarted the Mac, and also reinstalled Mathematica 5.1 from the 
original CD; no change.

???????????????????


  • Prev by Date: Re: Problems solving using Solve
  • Next by Date: Re: Problem with NMaximize
  • Previous by thread: "Freezing" evaluation Output?
  • Next by thread: Re: "Freezing" evaluation Output?