Services & Resources / Wolfram Forums
MathGroup Archive
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2006

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: JLink : JavaNew Failure

  • To: mathgroup at
  • Subject: [mg66263] Re: [mg66250] JLink : JavaNew Failure
  • From: Todd Gayley <tgayley at>
  • Date: Sat, 6 May 2006 01:54:37 -0400 (EDT)
  • Sender: owner-wri-mathgroup at

At 04:03 AM 5/5/2006, karenechu at wrote:
>Hello, everyone,
>I am very new to J/Link but I  have been fiddling with it for a while
>but I just don't see what was wrong:
>I wrote a hello world program in Java and compiled it and put it in a
>folder. Then I tried to call it from Mathematica using:
>All these go well with the new class path added and
>JavaClass["test",9] as output to the last line, but when:
>test1= JavaNew["test"];
>Mathematica failed to created object because " there is no constructor
>that takes zero arguments"   even though I put in an explicit
>constructor that takes no argument.
>I tried putting in a constructor taking an int as an argument and using
>test1= JavaNew["test",1]; (after reinstalling Java etc)
>but now the type of the argument is wrong.
>I think the class is either not properly loaded or something, but I
>just dont' know what is wrong!!
>Please help!


Sounds like you forgot to make the constructor public.

Todd Gayley
Wolfram Research

  • Prev by Date: Re: Determining Linear dependent vectors
  • Next by Date: Re: JLink : JavaNew Failure
  • Previous by thread: Re: JLink : JavaNew Failure
  • Next by thread: Re: JLink : JavaNew Failure