Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2006
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2006

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Mathematica Language Encoding in Linux?

  • To: mathgroup at smc.vnet.net
  • Subject: [mg66342] Re: [mg66304] Mathematica Language Encoding in Linux?
  • From: John Fultz <jfultz at wolfram.com>
  • Date: Wed, 10 May 2006 06:33:46 -0400 (EDT)
  • Reply-to: jfultz at wolfram.com
  • Sender: owner-wri-mathgroup at wolfram.com

It's not clear to me whether you understood my earlier point.  Your setting 
of LC_ALL breaks things because it has the side effect of implicitly 
changing LC_NUMERIC.  By explicitly setting LC_NUMERIC as I've described, 
you'll work around the problem while still achieving the (hopefully) 
desirable effects of setting LC_ALL.

Incidentally, if setting LC_ALL doesn't achieve the desired effects (you're 
running an old enough version that it's not very convenient for me to check 
the behavior myself) you may also want to try setting the option Formatting 
Options->Font Options->CharacterEncoding at global scope in the option 
inspector.

Sincerely,

John Fultz
jfultz at wolfram.com
User Interface Group
Wolfram Research, Inc.


On Tue, 9 May 2006 11:22:10 -0700 (PDT), ahmet nurlu wrote:
> Dear Fultz,
>
> Thanks for your reply. I have no problem running Mathematica in Linux.
> The system's settings was set to "en_US" encoding. But the problem is
> that I can't write some extended latin characters not defined in ISO-
> 8859-1 like, Dotted uppercase "I", dotless lowercase "i", upper- and
> lowercase "G" with breve accent, and upper- and lowercase "S" with
> cedilla. As I said, this problem is non-existent in Windows XP.
>
> The only solution which came to mind  was to set the system's setting to
> ISO-8859-9(Latin5) encoding. But, As you said, this prevents Mathematica
> running in Linux. I am getting a warning massage saying that:
>
> "The front end could not locate a character Encoding file for the
> requested encoding"
> and some other warnings.  I hope I could find a solution for the problem
> which prevents me and my students using our native language.
>
> Ahmet Nurlu
> John Fultz <jfultz at wolfram.com> wrote:
>> On Mon, 8 May 2006 00:46:59 -0400 (EDT), ahmet nurlu wrote:
>>
>>>
>>> I am a user of Mathematica 5.0 in Linux(Debian/testing). Sometimes, I
>>> need to prepare mathematica notebooks in my own Language(Turkish). I
>>> am
>>> not able to write Turkish inside Mathematica in Linux.
>>>
>>> I thought I could overcome this problem by changing language
>>> settings of
>>> the system from "en_US" to "tr_TR"(as by using "export LC_ALL=tr_TR"
>>> command) but this time, Mathematica refuses to run and gives some
>>> errors. I have also a windows version of Mathematica and this problem
>>> is non-existent in Windows. I wonder the non-English users of
>>> Mathematica could use their own language inside the Mathematica
>>> environment in Linux?
>>>
>>> Ahmet Nurlu
>>>
>> I don't know for certain how well Turkish will work in your version of
>> Mathematica, but I do know for certain what's causing the errors you're
>> seeing. There is a bug in your version of Mathematica (fixed in later
>> shipping versions) which causes problems when LC_NUMERIC is set to a
>> locale
>> that uses a character other than '.' for the decimal point.
>>
>> The workaround is easy. Just add
>>
>> export LC_NUMERIC=C
>>
>> along with your LC_ALL variable setting. You may also have to do a
>> clean
>> start of Mathematica, which you can do by adding the -cleanStart flag
>> to
>> your command-line (this should only be required the first time after
>> you
>> modify the environment).
>>
>> Sincerely,
>>
>> John Fultz
>> jfultz at wolfram.com
>> User Interface Group
>> Wolfram Research, Inc.
>
>
> Yahoo! Messenger with Voice. PC-to-Phone calls for ridiculously low
> rates.


  • Prev by Date: Re: Mathematica Language Encoding in Linux?
  • Next by Date: Re: Mathematica Question
  • Previous by thread: Re: Mathematica Language Encoding in Linux?
  • Next by thread: 3D surface plotting