[Date Index] [Thread Index] [Author Index]
Re: glibc version problem
I also have trouble to install Mathematica 5.20 under Ubuntu 6.10, although I can install it under Ubuntu 6.06.1 successfully. The error massage in the InstallErrors file is [: 215: ==: unexpected operator Does anyone know how to solve the problem? Thanks, Xuelian Roman Cheplyaka wrote: > > I've been having trouble installing Mathematica 4.2 under Linux (Ubuntu > > 6.10). It appears the problem is that I have glibc version 2.4 which is > > too new for Mathematica 4.2 to handle. I don't think I can easily > > downgrade my glibc because that will break all sorts of other software > > which is expecting version 2.4. Does anyone know what versions of glibc > > Mathematica 5.2 is compatible with? If it is compatible with glibc 2.4 > > I'll probably just upgrade to Mathematica 5.2. > > Mathematica does not expect to any version of glibc, neither glibc > itself. However, it's linked against libc. > I guess your problem is that Mathematica 4.2 is linked against libc5, > while glibc is providing libc6. > In this case you can safely install libc5, it must not conflict with > libc6. If Ubuntu does not ship one, you can try to borrow it from > Debian (http://packages.debian.org/stable/oldlibs/libc5). > > Answering your question: yes, Mathematica 5.2 is linked against libc6. > I have glibc 2.3.6, but I believe there would not be any problem with > glibc 2.4.