Services & Resources / Wolfram Forums
MathGroup Archive
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2007

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: eps exports with dashes in them (important - to me, anyway)

  • To: mathgroup at
  • Subject: [mg73008] Re: eps exports with dashes in them (important - to me, anyway)
  • From: "Chris Chiasson" <chris at>
  • Date: Sun, 28 Jan 2007 01:40:00 -0500 (EST)
  • References: <>

Thanks for the reply.

FontType->Outline didn't help. It appears that even though my
$FrontEnd AbsoluteOptions have FontType->Bitmap by default, that
Export generates the EPS using FontType->Outline. In fact, when I
change your command to say "FontType"->"Bitmap" the fraction bar and
the square root "roof" become solid (not dashed) and blocky/ugly.

I put my FontType->Bitmap result up at

as windows_BMP.eps, along with some files that give the contents of my
C:\Windows\Fonts directory before and after the install of MS Office
(and, no, its install didn't affect the EPS dashing, AFAIK).

Unfortunately, I don't have a before/after directory listing for the
installation of the MathML fonts for Firefox. However, the presence of
the "EPS dashing" appears to be unrelated to the MathML fonts because
I have had all four possible combinations of "ML fonts present
(yes/no)" & "EPS dashing (yes/no)" on this same computer.

I wish I knew what changed in the days between my last generation of a
correct EPS and the first generation of an incorrect EPS (at that
point, I hadn't reinstalled anything). I did change some of the
services that ran in Windows, so I though that might be the cause.
Before I reinstalled by using my OEM image, I spent a long time
switching services on and off to see if I could find a service (or
lack thereof) that fixed the EPS dashing problem. I didn't find one. I
was also really surprised when I encountered the same problem in
Mathematica that I had before the re-install.

P.S. There appears to be an unusually large jump in Magnification when
moving between these two settings:


On 1/27/07, ragfield <ragfield at> wrote:
> Chris, my reply to the list didn't appear to make it through:
> Have you installed or removed any fonts (or applications which may
> contain fonts) that may have caused the change in behavior?  You can
> alter the appearance by explicitly specifying "FontType"->"Outline":
> Export["~/Desktop/test.eps", StyleBox[ToBoxes@Sqrt[21/x],
>    PrivateFontOptions -> {"FontType" -> "Outline"}]]
> This problem will be fixed in a future release of Mathematica.
> -Rob
> Wolfram Research


  • Prev by Date: Re: Different results for same integration
  • Next by Date: Numerical quantifier elimination
  • Previous by thread: Re: eps exports with dashes in them (important - to me, anyway)
  • Next by thread: Re: when draw the piechart,how to write the label outside