Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2007
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2007

[Date Index] [Thread Index] [Author Index]

Search the Archive

Remote Kernel does nothing

  • To: mathgroup at smc.vnet.net
  • Subject: [mg73026] Remote Kernel does nothing
  • From: "Christoph Lhotka" <lhotka at astro.univie.ac.at>
  • Date: Tue, 30 Jan 2007 06:24:10 -0500 (EST)

Hello!

I have set up a remote Kernel on a Unix machine, the front end is on a windows
machine using the following options in the Kernel configurations menu:

plink lhotka@remoteip /usr/local/bin/math -mathlink -LinkMode Connect
-LinkProtocol TCPIP -LinkName "`linkname`" -LinkHost `hostip`

I have tried various different commandline options (from The FAQ, PCT, Network
Programming with Mathematica, etc...)

This version starts a kernel on the remote machine (without a password prompt)
- I see it starting up on the remote machine using top -u lhotka, but it does
nothing.

The situation is as follows: I In the frontend (on the host) I enter some
input, the frontend starts a Kernel on the remote machine, nothing comes back.
Any time I enter some input another Kernel is started, but nothing returns.

Can somebody please explain me - as detailed as possible - what I should do, I
have no idea to find out. For sure there is no easy way to establish a
conection between a Frontend and a Kernel over the network, promised by
Wolfram Research.

Thanks in advance,

Christoph 


  • Prev by Date: Re: Re: Sequence of Bernoulli RVs
  • Next by Date: Re: Movie clips to Mathematica
  • Previous by thread: Re: How to do quickest
  • Next by thread: PowerMod[] - Mathematica 5.0 - problem/error/bug?