MathGroup Archive 2007

[Date Index] [Thread Index] [Author Index]

Search the Archive

RE: Re: MatrixPlot: frame ticks starting with 0?


I need to assign to i? I don't quite get it.  The code as it is answers
Robin's question of forcing the numbering to start at 0 (apparently he wants
to see the matrix indices in C-style or so). As a matter of illustration I
showed the slots for all frame sides.  Your code doesn't start the numbering
at 0, BTW.

 

From: bsyehuda at gmail.com [mailto:bsyehuda at gmail.com] 
Sent: 20 June 2007 11:48
To: nazdrovje at gmail.com
Cc: mathgroup at smc.vnet.net
Subject: [mg77997] Re: [mg77937] Re: MatrixPlot: frame ticks starting with 0?

 

Well you practically forced this with the second element assigned to i-1.
you need to assign it to i but then there is no need to use two arguments
If you want only bottom and left ticks you can do it the following way 
MatrixPlot[RandomReal[{5, 10}, {5, 5}], 
 FrameTicks -> {Range[5],Range[5]}]
yehuda

On 6/20/07, nazdrovje at gmail.com  <mailto:nazdrovje at gmail.com>
<nazdrovje at gmail.com> wrote:

On Jun 19, 1:09 pm, robin.gr... at gmail.com wrote:
> Hi,
> I wonder how I can make MatrixPlot in Mathematica v6 to start the
> labeling of the frame ticks with 0? It allways starts the labeling 
> with 1.
> Greetings,
> Robin
See the eample below:

MatrixPlot[RandomReal[{5, 10}, {5, 5}],
FrameTicks -> {{Table[{i, i - 1}, {i, 5}],
    None}, {Table[{i, i - 1}, {i, 5}], None}}] 



  • Prev by Date: Re: Same Limit: OK in 5.2, fails in 6.0; Packages gone in 6.0 ???
  • Next by Date: Re: Audio
  • Previous by thread: Re: Re: MatrixPlot: frame ticks starting with 0?
  • Next by thread: Re: MatrixPlot: frame ticks starting with 0?