Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2007
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2007

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Re: MathPlayer???

  • To: mathgroup at smc.vnet.net
  • Subject: [mg75575] Re: [mg75535] Re: MathPlayer???
  • From: Murray Eisenberg <murray at math.umass.edu>
  • Date: Sat, 5 May 2007 06:08:59 -0400 (EDT)
  • Organization: Mathematics & Statistics, Univ. of Mass./Amherst
  • References: <f1c51i$h9s$1@smc.vnet.net> <200705040817.EAA05033@smc.vnet.net>
  • Reply-to: murray at math.umass.edu

I had this problem too today after installing Mathematica Player on a 
Windows 32-bit machine. Mathematica Player quit with an error message 
(giving an assertion failure error) immediately after opening.  And then 
upon starting Mathematica 5.2, that quit with winFonts assertion error.

After speaking with Wolfram tech support, I did the same thing as you 
(but rebooting after deleting the fonts from the Windows Fonts folder 
and before re-installing them from the directory you mention from 
Mathematica Player.

However, this is an error I had experienced (on a different Windows 
machine) several Mathematica versions ago that would occur whenever I 
installed a new version (this was prior to 5.2, which avoided the 
error).  I'm pretty sure my experience then was due to my using Adobe 
Type Manager (Deluxe, version 4.2) on that machine.  And I think the 
conflict was due to a problem with the length of the Mathematica font 
names -- some being longer than the maximum that ATM can regard as 
distinct fonts.

Since I am also using ATM on the machine where I had the font issue with 
Mathematica Player today, I assumed the difficulty there also had root 
cause ATM.  From what you say, maybe not.  (Or do you, too, use ATM?)

Drago Ganic wrote:
> [See the previous posts on this topic by John Fultz - moderator]
> 
> 
> Hi,
> I had the same problem on an Windows XP 32 bit verson. My problems were 
> connected with the Mathematica fonts.
> 
> Just copy the Mathematica fonts from The MathPlayer location
> 
>     C:\Program Files\Wolfram Research\Mathematica 
> Player\6.0\SystemFiles\Fonts\TrueType
> 
> to
>     C:\WINDOWS\Fonts.
> 
> If you still have any problems, delete those fonts from C:\WINDOWS\Fonts and 
> copy them again.
> 
> It worked for me. 'Hope it will work for you too :-)
> 
> Greetigns from Croatia,
> Drago
> 
> 
> "Christoph Lhotka" <lhotka at astro.univie.ac.at> wrote in message 
> news:f1c51i$h9s$1 at smc.vnet.net...
>> Dear Math Group!
>>
>> Has anyone installed the new MathPlayer of Mathematica version 6?
>> Please don't do so!
>>
>> On my computer the old Mathematica (5.2) version stopped working after
>> installation! Even a reinstallation of the old Mathematica version does 
>> not
>> solve the problem! The Front End to Kernel connection can not be 
>> established,
>> seems to stay in an infinite loop...
>>
>> Is there any help outside, so that I can at least continue my work?
>>
>> I am very annoyed about this issue.
>>
>> Christoph
>>
> 
> 
> 

-- 
Murray Eisenberg                     murray at math.umass.edu
Mathematics & Statistics Dept.
Lederle Graduate Research Tower      phone 413 549-1020 (H)
University of Massachusetts                413 545-2859 (W)
710 North Pleasant Street            fax   413 545-1801
Amherst, MA 01003-9305


  • Prev by Date: Re: [Mathematica 6] What happened to the 5.2 HELP interface?
  • Next by Date: Re: Sometimes <space> means multiple
  • Previous by thread: Re: MathPlayer???
  • Next by thread: Re: MathPlayer???