Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2007
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2007

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: drawing with mathematica

  • To: mathgroup at smc.vnet.net
  • Subject: [mg75925] Re: drawing with mathematica
  • From: Szabolcs <szhorvat at gmail.com>
  • Date: Sun, 13 May 2007 05:53:36 -0400 (EDT)
  • Organization: University of Bergen
  • References: <f23qs4$oar$1@smc.vnet.net>

dimitris wrote:
> Hello.
> 
> I have the following drawing.
> 
> zar = Graphics[{Thickness[0.007], Arrow[{0, -7}, {0, -7.5}, HeadLength
> -> 0.04, HeadWidth -> 0.5, HeadCenter -> 0]}];
>
> The arrow with the name zar (the vertical one!) appeared in
> undesirable form.
> Can somebody point me out a way to "fix" its appearance and all of the
> arrows
> objects to appeared with the same form?
> 

I believe that this is a bug in the PostScript renderer used by 
Mathematica because this problem does not appear when the drawing is 
exported as EPS.

When making figures like this you may find it helpful to preview them 
directly in an external application, like GSview, e.g. on Windows use 
something like

gsTempFile = ToFileName[$TemporaryPrefix, "mma_ghost.eps"]

(* no spaces in the path! *)
gsview = "C:\\Progra~1\\Ghostgum\\gsview\\gsview32.exe"

gsDisplay[gr_] :=
	(Display[gsTempFile, gr, "EPS"];
	 Run["start", gsview, "-e", gsTempFile];
	 gr)

$DisplayFunction = gsDisplay

and in GSview, set Options -> EPS clip.

I use this because in the front end the fonts do not appear correctly 
(wrong size).

http://www.cs.wisc.edu/~ghost/gsview/


  • Prev by Date: Re: graphics
  • Next by Date: Re: Jlink executable
  • Previous by thread: drawing with mathematica
  • Next by thread: Re: drawing with mathematica