Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2008

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: How do I set PlotRegion value permantly?

  • To: mathgroup at smc.vnet.net
  • Subject: [mg91047] Re: How do I set PlotRegion value permantly?
  • From: Jens-Peer Kuska <kuska at informatik.uni-leipzig.de>
  • Date: Mon, 4 Aug 2008 03:25:58 -0400 (EDT)
  • References: <g6emsu$cnb$1@smc.vnet.net>

Hi,

and you are sure, that you don't mean PlotRangePadding ?

Regards
   Jens


Tyler wrote:
> Hello All:
> 
> My apologies if this is a newbie question, but I cannot seem to find
> anything that helps me out. First off, yes, it is Friday night and I'm
> playing around with Options in Mathematica. Ouch. Okay, but I can deal
> with that. What I am struggling with, however, is this simple
> question: How do I set a default for PlotRegion->{{0.1,0.9},
> {0.1,0.9}}?
> 
> For all of my 2D plots/*listplots. I just want to add a small margin
> as i like to keep Frame->True.
> 
> Now, here is what I have tried to no avail.
> 
> (1) Edit with the Option Inspector. Seems like I can click on the
> value to edit it, but as soon as I click away, it returns to the
> default.
> 
> (2) Editing $UserBaseDirectory/FrontEnd/init.m
> 
> I've tried adding either
> 
> SetOption[Graphics,PlotRegion->{{0.1,0.9},{0.1,0.9}}]
> 
> or
> 
> Graphics[PlotRegion->{{0.15,0.85},{0.15,0.85}}]
> 
> Both of which were bad ideas, or so I gathered from the error message
> windows. Yikes!
> 
> (3) Editing $UserBaseDirectory/Kernel/init.m with the same values
> above, no error windows now, but also no effect it seems.
> 
> For what it's worth I have Mathematica 6.0 on Kubuntu 8.04 (Linux)....
> 
> Any ideas?
> 
> Cheers,
> 
> t.
> 


  • Prev by Date: Re: help with "no more memory" at mathematica
  • Next by Date: Re: evaluations in Plot in Manipulate?
  • Previous by thread: Re: Re: Method Option
  • Next by thread: Re: evaluations in Plot in Manipulate?