Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2008

[Date Index] [Thread Index] [Author Index]

Search the Archive

PrintingStyleEnvironment [was Re: Inset problems & Export]

  • To: mathgroup at smc.vnet.net
  • Subject: [mg85732] PrintingStyleEnvironment [was Re: Inset problems & Export]
  • From: Alan <ahs613_at_gmail_dot_com at invalid.invalid>
  • Date: Wed, 20 Feb 2008 07:00:25 -0500 (EST)

On Dec 11, 2007 Rob <ragfield at gmail.com> wrote:

> EPS (and PDF) export uses the PrintingStyleEnvironment option (which
> by default is set to "Printout"), and this seems to be what is causing
> the problem with Inset. You can work around this problem by
> temporarily setting this option to "Working" instead of "Printout".
> 
> (* record the old value of the PrintingStyleEnvironment option *)
> oldopts = Options[$FrontEnd, PrintingStyleEnvironment];
> 
> (* set the value to "Working" *)
> SetOptions[$FrontEnd, PrintingStyleEnvironment -> "Working"];
> 
> (* your export code here *)
> 
> (* reset the option to the original value *)
> SetOptions[$FrontEnd, oldopts];

This tip worked but I thought it could be done using the Options 
Inspector. The popup menu in the Options Inspector didn't give any other 
choices for PrintingStyleEnvironment when I tried to change it for the 
Selected Notebook - is it supposed to?  (I want to print out notes for 
lecturing in Working since Printout is too small for my aging eyes when 
my notes are on the desk!)

Thanks,

Alan


  • Prev by Date: Re: Plotting points of the function at increments.
  • Next by Date: Re: Sterographic display
  • Previous by thread: Re: Inset headache
  • Next by thread: Using Mathematica figures in MS Word documents