Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2008

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Bold Script Characters in 6.0.2

  • To: mathgroup at smc.vnet.net
  • Subject: [mg86203] Re: Bold Script Characters in 6.0.2
  • From: Peter Breitfeld <phbrf at t-online.de>
  • Date: Thu, 6 Mar 2008 02:55:52 -0500 (EST)
  • References: <fqlmpq$jfc$1@smc.vnet.net>

David Park schrieb:
> I wonder how many people see this bug in Version 6.0.2? (I'm on 32-bit 
> Windows Vista.)
>
> Type (or paste in from the Special Characters Script palette):
>
> \[ScriptCapitalF]//TraditionalForm
>
> and evaluate. Everything should be all right. Then select the output cell 
> and use Menu, Format, Face, Bold to change the FontWeight to "Bold". The 
> output cell will go blank and you will obtain a Messages Window with the 
> error: INTERNAL SELF-TEST ERROR: NoteFont2|c|1783.
>
> Alternatively, start a Section head and type: This section heading contains 
> a Script \[ScriptCapitalF].
> Again you will obtain an error message and the Script F will not display.
>
> This happens for all Bold Script characters, but it does not happen for Bold 
> Greek, Gothic or DoubleStruck.
>
> This problem did not occur prior to Version 6.0.2.
>
> Part of the reason for this behavior can be seen by going to 
> WolframResearch\Mathematica\SystemFiles\Fonts\TrueType
> and looking at Mathematica5.ttf (the Plain Script characters) and
> Mathematica5b.ttf (supposedly the Bold Script characters).
> The last file contains no characters and this seems to be the case going 
> back to Version 5.2.
> But Mathematica5mb.ttf does appear to have Bold and probably monospaced 
> characters.
>
> I don't know what the true source of this problem is or why there was no 
> problem prior to Version 6.0.2 but it is certainly a bug.
>
> For me, on Windows Vista, Mathematica 6.0.2 has been the most annoying, 
> buggy and time consuming non-major update I have ever seen.
>
> -- 
> David Park
> djmpark at comcast.net
> http://home.comcast.net/~djmpark/
>
>
>
 I use Version 6.0.2 (PowerPC 32 bit) on Mac OS X 10.4.11 and here
 all displays fine. Maybe it's because on Mac Mathematica doesn't
 use .ttf fonts but Type1 fonts

Gruss Peter
-- 
==-==-==-==-==-==-==-==-==-==-==-==-==-==-==-==-==-==-==-==-==-==
Peter Breitfeld, Bad Saulgau, Germany -- http://www.pBreitfeld.de


  • Prev by Date: Re: 64-bit problems with Mac version
  • Next by Date: RE: Bold Script Characters in 6.0.2
  • Previous by thread: Re: Bold Script Characters in 6.0.2
  • Next by thread: Re: Bold Script Characters in 6.0.2