Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2008

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Re: Re: v.7.0 issues

  • To: mathgroup at smc.vnet.net
  • Subject: [mg93940] Re: [mg93855] Re: [mg93827] Re: v.7.0 issues
  • From: John Fultz <jfultz at wolfram.com>
  • Date: Sat, 29 Nov 2008 04:30:26 -0500 (EST)
  • Reply-to: jfultz at wolfram.com

No comment on the third issue, which I haven't tried.  As for the first two
issues...

1) Mathematica now has real contextual menus (it has for many years had a 
right-click menu, but the menu was fixed, never changing based upon context).  
This means that it now matters *where* you click.  If you have something 
selected and you click on that selection, you'll get options which pertain to 
the selection.  For example, if you have a multiple cell selection, you need to 
right-click on one of the selected cells.  If you click someplace else, you'll 
get a menu which allows you to paste where you clicked (or do other kinds of
transformations on whatever it was you clicked), which requires changing the
selection in most cases.

2) This isn't a situation I was very happy with.  Safari binds back and forward 
navigation to Command+[ and Command+].  One of the things we've tried to do in 
the help viewer is to support web browser memes, and so in version 7 we support 
the Safari method.  But doing so didn't leave any good openings for shortcuts 
for inserting matching brackets/braces.  In the end, we elected to use 
Command+Option+] and Command+Option+Shift+] for these cases.  If you'd much
rather have the old keyboard shortcuts back, let me know and I can walk you
through reverting them.

Sincerely,
 
John Fultz
jfultz at wolfram.com
User Interface Group
Wolfram Research, Inc.


On Thu, 27 Nov 2008 05:30:29 -0500 (EST), DrMajorBob wrote:
> I have three issues.
>
> $Version
>
> "7.0 for Mac OS X x86 (64-bit) (November 11, 2008)"
>
> Problem 1: I'm used to highlighting several cells, right-clicking, and
> selecting copy or paste. This no longer works, as right-clicking causes
> NOTHING to be selected, before I can copy or paste.
>
> Problem 2: I'm used to hitting Command+[ to get [] or Command+Shift+[ to
> get {}. Neither of these do anything, now.
>
> Problem 3: loading David Parks' Presentations package in Init.m, with
> these statements (in two cells):
>
> Needs["Presentations`Master`"];
>
> help := PresentationsHelp
>
> yields the error:
>
> SetDelayed::write:
> Tag comment in comment[x_, action_:FrontEnd`NotebookWrite] is Protected.
>
> Bobby





  • Prev by Date: Re: Comment display style?
  • Next by Date: Re: Floating-Point Computing
  • Previous by thread: Re: v.7.0 issues
  • Next by thread: Re: v.7.0 issues