Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2009

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Package won't load after v.7 upgrade

  • To: mathgroup at smc.vnet.net
  • Subject: [mg102319] Re: Package won't load after v.7 upgrade
  • From: David Reiss <dreiss at scientificarts.com>
  • Date: Wed, 5 Aug 2009 05:44:52 -0400 (EDT)
  • References: <h58rbr$q3o$1@smc.vnet.net>

Hmmmm.  I assume that you are placing the integExp.m file in
ToFileName[{$UserAddOnsDirectory, "Applications"}].  If so then this
should work so long as the BeginPackage statement in integExp.m  reads

BeginPackage["integExp`"]

(i.e., that the context in the BeginPackage is integExp` and not
something more complex such as MyContext`integExp`)

and also so long as, for example the filename integExp.m  doesn't have
any accidental added spaces.

Have you taken a peak inside the integExp.m file to make sure that it
isn't corrupted in any way?

...just some thoughts on what might have gone wrong...

Best,
David




On Tue, Aug 4, 2009 at 8:19 PM, Porscha Louise McRobbie
<pmcrobbi at umich.edu> wrote:
>
> Thanks for the info.
>
> However, if I place my package integExp.m in the directory below (which is what I'd done originally, but since it didn't work I thought it was wrong), I still get the errors:
>
> Needs["integExp`"]
> Needs::nocont: Context integExp` was not created when Needs was evaluated. >>
>
> ?integExp
> Information::notfound: Symbol integExp not found. >>
>
> I do see the correct directory listed with $Path.  Any other thoughts?
>
>
> Quoting David Reiss <dbreiss at gmail.com>:
>
>> Hi,
>>
>> As a general rule you **never** want to put your applications within
>> the Mathematica.app directory.  This modifies your Mathematica
>> application itself and, when you upgrade your Mathematica version
>> everything that you place there will be removed.  Rather you want to
>> put it in:
>>
>> ToFileName[{$UserAddOnsDirectory, "Applications"}]
>>
>> This directory is persistent through upgrades to Mathematica and is
>> always contained in $Path.
>>
>> I hope thei helps.
>>
>> --David
>> http://scientificarts.com/worklife
>>
>>
>>
>>
>> On Aug 4, 4:26 am, Porscha Louise McRobbie <pmcro... at umich.edu> wrote:
>>>
>>> I should add to my previous message that I also checked the global
>>> variable $Path, and didn't see the path to my AddOn listed there. I
>>> tried  using
>>>
>>> Prepend[$Path,"/Applications/Mathematica.app/AddOns/ExtraPackages/Quantum"]
>>>
>>> After which when I type $Path I do see the path to my AddOn. However,
>>> it still won't load.
>>>
>>> Thanks,
>>> Porscha
>>
>>
>>
>>
>



--
This message and any attachments, may contain confidential and/or
legally privileged information.  If you are not the intended
recipient of the message by the original sender, please destroy it.
Message and attachments copyright (c) 2009, all rights reserved.  Any
unauthorized dissemination, distribution or copying is strictly
forbidden.


  • Prev by Date: Re: Re: error with Sum and Infinity
  • Next by Date: Re: publicon
  • Previous by thread: Re: Package won't load after v.7 upgrade
  • Next by thread: Re: Package won't load after v.7 upgrade