Services & Resources / Wolfram Forums / MathGroup Archive

MathGroup Archive 2009

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Re: Package won't load after v.7 upgrade

  • To: mathgroup at
  • Subject: [mg102357] Re: [mg102315] Re: Package won't load after v.7 upgrade
  • From: "David Park" <djmpark at>
  • Date: Thu, 6 Aug 2009 06:33:27 -0400 (EDT)
  • References: <h58rbr$q3o$> <13039412.1249467921601.JavaMail.root@n11>

Create a Folder MyPackages, say, in the Applications folder. Make your
BeginPackage statement:


Load with:


David Park
djmpark at  

From: Porscha Louise McRobbie [mailto:pmcrobbi at] 

Thanks for the info.

However, if I place my package integExp.m in the directory below 
(which is what I'd done originally, but since it didn't work I thought 
it was wrong), I still get the errors:

Needs::nocont: Context integExp` was not created when Needs was evaluated.

Information::notfound: Symbol integExp not found. >>

I do see the correct directory listed with $Path.  Any other thoughts?

Quoting David Reiss <dbreiss at>:

> Hi,
> As a general rule you **never** want to put your applications within
> the directory.  This modifies your Mathematica
> application itself and, when you upgrade your Mathematica version
> everything that you place there will be removed.  Rather you want to
> put it in:
> ToFileName[{$UserAddOnsDirectory, "Applications"}]
> This directory is persistent through upgrades to Mathematica and is
> always contained in $Path.
> I hope thei helps.
> --David
> On Aug 4, 4:26 am, Porscha Louise McRobbie <pmcro... at> wrote:
>> I should add to my previous message that I also checked the global  
>> variable $Path, and didn't see the path to my AddOn listed there. I  
>> tried  using
>> After which when I type $Path I do see the path to my AddOn. However,  
>> it still won't load.
>> Thanks,
>> Porscha

  • Prev by Date: Re: solving for a second function
  • Next by Date: Re: LinearModelFit regression estimated variance error
  • Previous by thread: Re: Package won't load after v.7 upgrade
  • Next by thread: Re: Package won't load after v.7 upgrade