Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2009

[Date Index] [Thread Index] [Author Index]

Search the Archive

Forcing Mathematica to render by particular system font

  • To: mathgroup at smc.vnet.net
  • Subject: [mg95789] Forcing Mathematica to render by particular system font
  • From: lehin.p at gmail.com
  • Date: Tue, 27 Jan 2009 06:59:42 -0500 (EST)

Hello,
I wish to have symbols like \[HappySmiley] in notebooks to be rendered
by particular system font, not by Mathematica's font. But Mathematica
automatically replaces such symbols and renders them by it's own font.
I tried to use PrivateFontOptions option to turn off this behavior but
I have
failed. I have tried the following:

In[1]:= Style["\:263a \:263b",
 PrivateFontOptions -> {"OperatorSubstitution" -> False,
 "WindowsUseTrueTypeNames" -> False},
 FontFamily -> "Lucida Sans Unicode", Large]

Out[1]= \[HappySmiley] \:263b

But "\[HappySmiley]" is still rendered by Mathematica's font.
How to force rendering such symbols by system font?


  • Prev by Date: opacity "bleeds" in V7 graphics? [compared to V6]
  • Next by Date: Simplify problem
  • Previous by thread: Re: opacity "bleeds" in V7 graphics? [compared to V6]
  • Next by thread: Simplify problem