Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2009

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Reading csv with ;

  • To: mathgroup at smc.vnet.net
  • Subject: [mg99500] Re: Reading csv with ;
  • From: "Sjoerd C. de Vries" <sjoerd.c.devries at gmail.com>
  • Date: Thu, 7 May 2009 06:30:51 -0400 (EDT)
  • References: <gtp1h5$k58$1@smc.vnet.net>

Dennis,

It seems that with the standard Import of CSV files you are limited to
(by definition) comma separated values. However, you can Import them
as a table with a "FieldSeparators" option:

Import["FilePath//FileName.csv", "Table", "FieldSeparators" -> ";"]

Cheers - Sjoerd

On May 5, 11:39 am, Dennis <detebe... at hotmail.com> wrote:
> I'm trying to read a csv with mathematica=85
>
> Now the problem is that my system settings are at ";" as seperator instea=
d of more traditional ",". So the it effectively looks like 1;1;1;1 instead=
 of 1,1,1,1
>
> Normally this makes not difference as in most software you can choose the=
 delimiter/seperator before reading a file, so you pick =93separator = ;=
=94 or whatever.
>
> With mathematica however I have so far been unable to do this. Now the qu=
estion of course: how so I change the seperator with mathematica?
>
> Because quite a few files have a =93;=94 separator I would like to find a=
 solution within mathematica instead of changing the system settings.
>
> Cheers,
>
> Dennis



  • Prev by Date: Re: Picking Off Lists That Have No Numbers
  • Next by Date: Re: Remove quotes from Cell Expression
  • Previous by thread: Re: Reading csv with ;
  • Next by thread: Re: Reading csv with ;