Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2009

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Plotting in a dynamic environment.

  • To: mathgroup at smc.vnet.net
  • Subject: [mg99634] Re: Plotting in a dynamic environment.
  • From: mgoic <magoic at gmail.com>
  • Date: Sun, 10 May 2009 05:13:30 -0400 (EDT)
  • References: <gu3at0$t8t$1@smc.vnet.net>

BTW, in the actual problem I'm trying to solve, I don't to plot myfun
itself; I need to plot a different expression resulting from rather
long computations.

Regards,
Marcel Goic

On 9 mayo, 03:21, mgoic <mag... at gmail.com> wrote:
> Hi everyone,
>
> I am having problems when trying to plot an expression in a Dynamic
> model using manipulate tool. For example, in this simple code I can
> plot the function (first plot), I can evaluate its value in a
> manipulate environment (second plot), but when trying to plot in a
> dynamic environment I just get empty axis (third plot).
>
> myfun = x^2 + 3 t x ;
> t = 1;
> Plot[myfun, {x, 0, 2}]
> Clear[t]
> Manipulate[Evaluate[myfun], {x, 1, 2}, {{t, 1}, 0, 10}]
> Manipulate[Plot[Evaluate[myfun], {x, 1, 2}], {{t, 1}, 0, 10}]
>
> Any idea of what I am doing wrong? I will really appreciate any
> guidance.
>
> Regards,
> Marcel Goic



  • Prev by Date: Re: Replace specific element with specific value.
  • Next by Date: Re: Getting Workbench to Work
  • Previous by thread: Plotting in a dynamic environment.
  • Next by thread: Re: Plotting in a dynamic environment.