Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2009

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: what's wrong with these expressions?

  • To: mathgroup at smc.vnet.net
  • Subject: [mg104631] Re: what's wrong with these expressions?
  • From: Szabolcs Horvát <szhorvat at gmail.com>
  • Date: Thu, 5 Nov 2009 03:50:56 -0500 (EST)
  • References: <hcr9u7$9n3$1@smc.vnet.net>

On 2009.11.04. 8:19, dushan wrote:
> I defined two 3-D vector functions,
>      {Subscript[n,p][z_], Subscript[n,m][z_]} := {{p1[z],p2[z],p3[z]},
>                                                        {m1[z],m2[z],m3
> [z]}}
> where p? and m? are simple functions of z.  When displayed they appear
> as expected.  But when I tried to define the dyadics
>      {Subscript[nn,p][z_], Subscript[nn,m][z_]} :=
>                       {Outer[Times, Subscript[n,p][z], Subscript[n,p]
> [z]],
>                        Outer[Times, Subscript[n,m][z], Subscript[n,m]
> [z]]}
> I got the error message that the expression 'is incomplete, more input
> is needed'.

That error message usually indicated missing brackets.  However, the 
exact expressions that you posted do not produce any error messages. 
Did you use exactly these expressions or something slightly different?

>
> When I separate this into two independent commands, as
>      Subscript[nn,p][z_] := Outer[Times, Subscript[n,p][z],
>                                                Subscript[n,p][z]]
>      Subscript[nn,m][z_] := Outer[Times, Subscript[n,m][z],
>                                                Subscript[n,m][z]]
> no error is generated.  Probably irrelevant, but I noticed that in
> both cases the outer brackets of the 'm' definition were slightly
> smaller than those of the 'p' definition.
>
> To check the result I asked to display the inner product
>      Subscript[nn,p][z].Subscript[n,p][z]
> and got the error message 'Recursion depth 256 exceeded'.
>
> In fact, when, to reassure myself, I tried again to display Subscript
> [n,p][z], I got the same error message.  So I went back over the
> definitions, and this time
>      Subscript[nn,p][z].Subscript[n,p][z]
> produced the expected answer.
>
> What could possibly be changing that sometimes, but not always,
> produces the error messages in these two cases?  I'm at a loss to know
> what to watch out for.
>
> - Dushan
>



  • Prev by Date: Re: Mathematica and desktop search
  • Next by Date: Re: MathKernel7 produces no Graphics
  • Previous by thread: Re: what's wrong with these expressions?
  • Next by thread: Problems with absolute PlotRange