Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2009

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: what's wrong with these expressions?

  • To: mathgroup at smc.vnet.net
  • Subject: [mg104614] Re: [mg104606] what's wrong with these expressions?
  • From: DrMajorBob <btreat1 at austin.rr.com>
  • Date: Thu, 5 Nov 2009 03:47:40 -0500 (EST)
  • References: <200911040641.BAA09061@smc.vnet.net>
  • Reply-to: drmajorbob at yahoo.com

No problem here:

{Subscript[n, p][z_],
   Subscript[n, m][z_]} := {{p1[z], p2[z], p3[z]}, {m1[z], m2[z],
    m3[z]}}

{Null, Null}

(* testing *)
{Subscript[n, p][z], Subscript[n, m][z]}

{{p1[z], p2[z], p3[z]}, {m1[z], m2[z], m3[z]}}

{Subscript[nn, p][z_],
   Subscript[nn, m][z_]} := {Outer[Times, Subscript[n, p][z],
    Subscript[n, p][z]],
   Outer[Times, Subscript[n, m][z], Subscript[n, m][z]]}

{Null, Null}

(* testing *)
{Subscript[nn, p][z], Subscript[nn, m][z]}

{{{p1[z]^2, p1[z] p2[z], p1[z] p3[z]}, {p1[z] p2[z], p2[z]^2,
    p2[z] p3[z]}, {p1[z] p3[z], p2[z] p3[z], p3[z]^2}}, {{m1[z]^2,
    m1[z] m2[z], m1[z] m3[z]}, {m1[z] m2[z], m2[z]^2,
    m2[z] m3[z]}, {m1[z] m3[z], m2[z] m3[z], m3[z]^2}}}

Bobby

On Wed, 04 Nov 2009 00:41:31 -0600, dushan <dushanm at spinn.net> wrote:

> I defined two 3-D vector functions,
>     {Subscript[n,p][z_], Subscript[n,m][z_]} := {{p1[z],p2[z],p3[z]},
>                                                       {m1[z],m2[z],m3
> [z]}}
> where p? and m? are simple functions of z.  When displayed they appear
> as expected.  But when I tried to define the dyadics
>     {Subscript[nn,p][z_], Subscript[nn,m][z_]} :=
>                      {Outer[Times, Subscript[n,p][z], Subscript[n,p]
> [z]],
>                       Outer[Times, Subscript[n,m][z], Subscript[n,m]
> [z]]}
> I got the error message that the expression 'is incomplete, more input
> is needed'.
>
> When I separate this into two independent commands, as
>     Subscript[nn,p][z_] := Outer[Times, Subscript[n,p][z],
>                                               Subscript[n,p][z]]
>     Subscript[nn,m][z_] := Outer[Times, Subscript[n,m][z],
>                                               Subscript[n,m][z]]
> no error is generated.  Probably irrelevant, but I noticed that in
> both cases the outer brackets of the 'm' definition were slightly
> smaller than those of the 'p' definition.
>
> To check the result I asked to display the inner product
>     Subscript[nn,p][z].Subscript[n,p][z]
> and got the error message 'Recursion depth 256 exceeded'.
>
> In fact, when, to reassure myself, I tried again to display Subscript
> [n,p][z], I got the same error message.  So I went back over the
> definitions, and this time
>     Subscript[nn,p][z].Subscript[n,p][z]
> produced the expected answer.
>
> What could possibly be changing that sometimes, but not always,
> produces the error messages in these two cases?  I'm at a loss to know
> what to watch out for.
>
> - Dushan
>


-- 
DrMajorBob at yahoo.com


  • Prev by Date: Re: Finding Clusters
  • Next by Date: Re: MathKernel7 produces no Graphics
  • Previous by thread: Re: what's wrong with these expressions?
  • Next by thread: Re: Re: what's wrong with these expressions?