Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2009

[Date Index] [Thread Index] [Author Index]

Search the Archive

what's wrong with these expressions?

  • To: mathgroup at smc.vnet.net
  • Subject: [mg104606] what's wrong with these expressions?
  • From: dushan <dushanm at spinn.net>
  • Date: Wed, 4 Nov 2009 01:41:31 -0500 (EST)

I defined two 3-D vector functions,
    {Subscript[n,p][z_], Subscript[n,m][z_]} := {{p1[z],p2[z],p3[z]},
                                                      {m1[z],m2[z],m3
[z]}}
where p? and m? are simple functions of z.  When displayed they appear
as expected.  But when I tried to define the dyadics
    {Subscript[nn,p][z_], Subscript[nn,m][z_]} :=
                     {Outer[Times, Subscript[n,p][z], Subscript[n,p]
[z]],
                      Outer[Times, Subscript[n,m][z], Subscript[n,m]
[z]]}
I got the error message that the expression 'is incomplete, more input
is needed'.

When I separate this into two independent commands, as
    Subscript[nn,p][z_] := Outer[Times, Subscript[n,p][z],
                                              Subscript[n,p][z]]
    Subscript[nn,m][z_] := Outer[Times, Subscript[n,m][z],
                                              Subscript[n,m][z]]
no error is generated.  Probably irrelevant, but I noticed that in
both cases the outer brackets of the 'm' definition were slightly
smaller than those of the 'p' definition.

To check the result I asked to display the inner product
    Subscript[nn,p][z].Subscript[n,p][z]
and got the error message 'Recursion depth 256 exceeded'.

In fact, when, to reassure myself, I tried again to display Subscript
[n,p][z], I got the same error message.  So I went back over the
definitions, and this time
    Subscript[nn,p][z].Subscript[n,p][z]
produced the expected answer.

What could possibly be changing that sometimes, but not always,
produces the error messages in these two cases?  I'm at a loss to know
what to watch out for.

- Dushan


  • Prev by Date: Re: Mathematica and desktop search
  • Next by Date: Re: Re: Wrong Simplify[] Answer for
  • Previous by thread: Re: Set::setps error? Twitter.m's OOP-like approach?
  • Next by thread: Re: what's wrong with these expressions?