Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2009

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: remote kernel trouble

  • To: mathgroup at smc.vnet.net
  • Subject: [mg104699] Re: [mg104637] remote kernel trouble
  • From: John Fultz <jfultz at wolfram.com>
  • Date: Sat, 7 Nov 2009 06:48:09 -0500 (EST)
  • Reply-to: jfultz at wolfram.com

You say that the MathKernel is starting on the remote machine, so the ssh 
machinery worked.  Don't worry about where known_hosts got created...there may 
be a minor issue here, but it's not causing your principal problem.  And neither 
WolframSSH nor ssh itself will create a key on another machine.  There are, of 
course, options for you to do this manually and for these ssh implementations to 
use that key...but they don't work by creating anything on the remote system.  
There seems to be a little bit of confusion in general about ssh here, but as I 
said, let's set all of that aside.  You have confirmed (and I'll trust you did 
this via reliable means) that MathKernel was launched, and that means the ssh 
hurdle was cleared.

So, what are the other possible problems?  These are the ones I can think of...

* The command-line might not identify the machine running the FE correctly. If 
you can get the command-line which was run on the remote machine, check to see 
how it identified your machine, and then ping that location.  Did it work?

* You might have multiple network adapters on the FE machine, and the kernel
might not be connecting to the same adapter that the FE is listening on.

* There might be an intervening firewall blocking traffic on arbitrary ports.

The first two can be fixed by fiddling with the command-line which is sent via 
ssh.  The third, I'm afraid, is a real problem, for which there is no good 
solution.

Also, if you talk to Wolfram Tech Support, they can walk you through a process 
of manually launching an FE on one side, a kernel on the other, and hooking them 
up step by step in a way that will hopefully produce better feedback to what the 
real problem is (I could do this, too, but it'd about triple the length of this 
email, and I'm really very, very busy right now).

Sincerely,
 
John Fultz
jfultz at wolfram.com
User Interface Group
Wolfram Research, Inc.



On Thu, 5 Nov 2009 03:52:05 -0500 (EST), Ian wrote:
> I'm unable to start a remote kernel, and have not found a solution to
> my problem the archives. I'm running Mathematica 7.0 on Windows Vista,
> trying to start a remote kernel on a Linux server also running 7.0.
>
> I'm relying on WolframSSH.jar to make the connection, so I haven't
> fiddled with the advanced settings under kernel configuration
> options.  (Well, I've tried without success to use putty to make the
> connection). When I evaluate the first command in a notebook using the
> remote kernel, I get the authentication key question and then enter a
> password, and then nothing happens. The notebook claims to be running
> but never evaluates, there's no error message, and Mathematica locks
> up.
>
> I can see that a MathKernel does start on the remote machine, so the
> login at least is successful. And force closing Mathematica locally
> kills the remote kernel.
>
> The only clue I can discover is that Mathematica wants to put the RSA
> key in the wrong place. My username on both machines is
> "carroll" (which I can confirm Mathematica knows with $UserName), but
> it creates the known_hosts file in "C:\Users\Ian\.ssh\" which wouldn't
> otherwise exist. I also don't see any key created on the remote
> machine. Could this cause the problem? What else should I try doing?
>
> Thanks
> -Ian
> (* apologies if this is a double post, the first vanished *)





  • Prev by Date: Re: Re: remote kernel trouble
  • Next by Date: Re: Mathematica skill level snippet(s)
  • Previous by thread: Re: Re: remote kernel trouble
  • Next by thread: Re: MathKernel7 produces no Graphics