Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2009

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Re: remote kernel trouble

  • To: mathgroup at smc.vnet.net
  • Subject: [mg104715] Re: [mg104655] Re: remote kernel trouble
  • From: Zach Bjornson <bjornson at mit.edu>
  • Date: Sat, 7 Nov 2009 06:51:21 -0500 (EST)
  • References: <hcu5jr$m9d$1@smc.vnet.net> <200911061015.FAA07970@smc.vnet.net>

Hi Ian,

It sounds like you're doing more than is necessary, but I might be 
misunderstanding your e-mail. My replies are interspersed below.

On 11/6/2009 5:15 AM, Ian wrote:
> Thanks to help from bj...@mit, but I'm still not there. I'm now
> getting a msg "The kernel cruncher failed to connect to the front end.
> (Error = MLECONNECT). You should try running the kernel connection
> outside the front end." I tried, but what sort of behavior is good or
> bad?
>
> My configuration on a Windows Vista machine running Mathematica 7.0 is
>
> Arguments to MLOpen:
> -LinkMode Listen -LinkProtocol TCPIP -LinkOptions MLDontInteract
>    
Try using the *exact* ML string that I sent in my instructions. The 
linkmode needs to be connect; you need to specify a host name, ML needs 
to interact, etc. This looks more like a slave string, but I don't know 
where you got it.
> Shell command to launch kernel:
> plink -i keyfile carroll@cruncher -x math -mathlink -linkmode Connect -
> linkprotocol TCPIP -linkname "`linkname`" -linkhost `ipaddress`
>    
> When I run exactly this from cmd line in Vista, I get
>    
>> bash: linkname: command not found
>> bash: ipaddress: command not found
>>      
You shouldn't be running anything from the Windows shell except for 
diagnostics. Mmeca launches the remote kernel on its own. The syntax you 
wrote is specific to Mmeca as well (the `linkname` part, at least)
>    
>> LinkOpen::linke: --Message text not found -- (MathLink linkname missing or malformed.)
>>      
> When from the cmd line in Vista I run
> plink -i keyfile carroll@cruncher -x math -mathlink -linkmode Connect -
> linkprotocol TCPIP -linkname 5301 at local.machine
>
> there's no message, and I have to ctrl-C to get back to the cmd
> prompt. a MathKernel does start on cruncher. should something else
> happen?
>
>    
If your connection is successful from a command line (e.g. if you "ssh 
yourserver math" you should get a Mathematica command line interface ">" 
and be able to e.g. type 1+1 and get 2).
> thanks for any help!
> -Ian
>
>
>    
Try following my instructions exactly; I think that will clear up your 
problem. You don't need to do anything outside of Mmeca to use the 
remote kernel after you set it up.
Cheers,
Zach
> On Nov 5, 1:24 am, Ian<carroll.... at gmail.com>  wrote:
>    
>> I have followed the very simple instructions for setting up a remote
>> kernel in Mathematica 7.0 on Windows Vista, but my connection is not
>> working. I believe the source of the problem is the location of the
>> ssh keys. After telling a notebook to start the remote kernel, I get
>> to a dialog which says:
>>
>> "C:\Users\Ian\.ssh\known hosts does not exist Are you sure you want to
>> create it?"
>>
>>   My username is "carroll" not "Ian", and Mathematica knows this:
>>
>>   In = $UserName
>> Out = carroll
>>
>> "carroll" is also my username on the remote machine. How do I force
>> Mathematica to create and look for the known_hosts file in "C:\Users
>> \carroll\.ssh\"?
>>
>> And yes, even if I let the known_hosts file get created in Users\Ian
>> \.ssh, the connection still does not work.
>>
>> Thanks
>> -Ian
>>      
>
>    


  • Prev by Date: Re: Finding Clusters
  • Next by Date: Re: remote kernel trouble
  • Previous by thread: Re: remote kernel trouble
  • Next by thread: Re: remote kernel trouble