Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2010

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: remote kernel problem

  • To: mathgroup at smc.vnet.net
  • Subject: [mg111687] Re: remote kernel problem
  • From: Nate Dudenhoeffer <dudenhoeffer at wisc.edu>
  • Date: Tue, 10 Aug 2010 03:56:21 -0400 (EDT)

My launch command looks the same with the exception that instead of having
the host name I have the IP address including the port (22).  That wouldn't
be practical if you have a dynamic IP, but you could use the current IP to
see if that's where the issue is.

I also use a ssh key pair without a password, but that shouldn't make any
difference.

Nate

On Mon, Aug 9, 2010 at 6:29 PM, Cristobal Navarro <axischire at gmail.com>wrote:

> i tested what you suggested Nate,
>
> instead of just puting "math" in the argument.
> i put complete path
>
> /usr/local/bin/math
>
> but i get the same error when testing a 2+2 example.
>
> if this is useful:
> the arguments of MLOpen:
> -LinkMode Listen
> -LinkProtocol TCPIP
> -LinkOptions MLDontInteract
>
> the arguments of shell command to launch kernel
> `java` -jar `mathssh` fcluster@agua /usr/local/bin/math -mathlink
> -LinkMode Connect -LinkProtocol TCPIP -LinkName "`linkname`" -LinkHost
> `ipaddress`
>
> fcluster is the account on the remote node which has hostname "agua".
> my laptop uses another account, from what i know it is not necesary to have
> the same username on both nodes right?
>
> On Mon, Aug 9, 2010 at 5:31 PM, Nate Dudenhoeffer <dudenhoeffer at wisc.edu>wrote:
>
>> Cristobal,
>>
>> I had a similar problem setting up remote kernels on Mac OS.  In the
>> kernel configuration try putting the complete path to the kernel, instead of
>> simply "math."
>>
>> On Mac OS the path is:
>> /Applications/Mathematica.app/Contents/MacOS/MathKernel
>>
>> Regards,
>> Nate
>>
>> On Mon, Aug 9, 2010 at 4:13 AM, Cristobal Navarro <axischire at gmail.com>wrote:
>>
>>> hello,
>>>
>>> i am having problems launching remote kernels.
>>> i have a Xeon server (Linux) on which mathematica is installed, and
>>> the "math" command works.
>>>
>>> on my laptop, i have linux too, and on mathematica i add the kernel to
>>> be launched on the remote (the server)  node.
>>> then i try one example:
>>> 2+2
>>>
>>> i press shift+enter... mathematica asks me to insert the password of
>>> the remote node user name.... ok  and then i get error message:
>>>
>>> "The kernel serverKernel failed to connect to the front end. (Error =
>>> MLECONNECT). You should try running the kernel connection outside the
>>> front end."
>>>
>>> for debugging purposes, i made a kernel for my same laptop, just like
>>> a "Local" kernel but i choose remote and put my ip adress and my
>>> useracount of my laptop.
>>>
>>> i test 2+2, it asks my password..ok, then the same message:
>>>
>>> "The kernel self failed to connect to the front end. (Error =
>>> MLECONNECT). You should try running the kernel connection outside the
>>> front end."
>>>
>>> this is really weird.
>>>
>>> the parameters of the "self kernel" are this:
>>> `java` -jar `mathssh` fcluster@agua math -mathlink -LinkMode Connect -
>>> LinkProtocol TCPIP -LinkName "`linkname`" -LinkHost `ipaddress`
>>>
>>> if remote kernel does not work with my same computer, i better not
>>> keep trying with the server yet.
>>>
>>> any help is welcome, i really dont know what is going on.
>>>
>>> best regards
>>> Cristobal.
>>>
>>>
>>>
>>
>


  • Prev by Date: Problem overwriting init.m file
  • Next by Date: How to display a popup showing just items list view?
  • Previous by thread: Re: remote kernel problem
  • Next by thread: Re: remote kernel problem