Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2010

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: remote kernel problem

  • To: mathgroup at smc.vnet.net
  • Subject: [mg111720] Re: remote kernel problem
  • From: Cristobal Navarro <axischire at gmail.com>
  • Date: Wed, 11 Aug 2010 04:47:54 -0400 (EDT)

has someone been able to make it work with linux --> linux ??

On Tue, Aug 10, 2010 at 10:40 AM, Cristobal Navarro <axischire at gmail.com>wrote:

> i managed to use a mac laptop as frontend to connect to the linux server.
> and it worked!
>
> why could it not work when doing Linux --> Linux, both ubuntu 10.04 ?
> the linux laptop is 32-bit, and the remote kernel node has ubuntu server
> 64-bit but that shouldnt be a problem since it is ssh comunication.
>
> mmm, at least the remote node is Ok, the problem is when i try to run from
> my linux laptop
>
> On Tue, Aug 10, 2010 at 8:51 AM, Nate Dudenhoeffer <dudenhoeffer at wisc.edu>wrote:
>
>> Here is my launch command:
>> `java` -jar "`mathssh`" nate at xxx.xxx.xxx.xxx:22
>> /Applications/Mathematica.app/Contents/MacOS/MathKernel -mathlink -LinkMode
>> Connect -LinkProtocol TCPIP -LinkName "`linkname`" -LinkHost `ipaddress`
>>
>> Nate
>>
>>
>> On Tue, Aug 10, 2010 at 2:56 AM, Cristobal Navarro <axischire at gmail.com>wrote:
>>
>>> i also tried and it didnt work.
>>> all i know is that ssh is not the problem because i always everyday with
>>> it
>>> on the remote node.
>>>
>>> could you copy to me your arguments ??
>>> thanks!
>>>
>>> On Mon, Aug 9, 2010 at 7:36 PM, Nate Dudenhoeffer <dudenhoeffer at wisc.edu
>>> >wrote:
>>>
>>> > My launch command looks the same with the exception that instead of
>>> having
>>> > the host name I have the IP address including the port (22).  That
>>> wouldn't
>>> > be practical if you have a dynamic IP, but you could use the current IP
>>> to
>>> > see if that's where the issue is.
>>> >
>>> > I also use a ssh key pair without a password, but that shouldn't make
>>> any
>>> > difference.
>>> >
>>> > Nate
>>> >
>>> >
>>> > On Mon, Aug 9, 2010 at 6:29 PM, Cristobal Navarro <axischire at gmail.com
>>> >wrote:
>>> >
>>> >> i tested what you suggested Nate,
>>> >>
>>> >> instead of just puting "math" in the argument.
>>> >> i put complete path
>>> >>
>>> >> /usr/local/bin/math
>>> >>
>>> >> but i get the same error when testing a 2+2 example.
>>> >>
>>> >> if this is useful:
>>> >> the arguments of MLOpen:
>>> >> -LinkMode Listen
>>> >> -LinkProtocol TCPIP
>>> >> -LinkOptions MLDontInteract
>>> >>
>>> >> the arguments of shell command to launch kernel
>>> >> `java` -jar `mathssh` fcluster@agua /usr/local/bin/math -mathlink
>>> >> -LinkMode Connect -LinkProtocol TCPIP -LinkName "`linkname`" -LinkHost
>>> >> `ipaddress`
>>> >>
>>> >> fcluster is the account on the remote node which has hostname "agua".
>>> >> my laptop uses another account, from what i know it is not necesary to
>>> >> have the same username on both nodes right?
>>> >>
>>> >> On Mon, Aug 9, 2010 at 5:31 PM, Nate Dudenhoeffer <
>>> dudenhoeffer at wisc.edu>wrote:
>>> >>
>>> >>> Cristobal,
>>> >>>
>>> >>> I had a similar problem setting up remote kernels on Mac OS.  In the
>>> >>> kernel configuration try putting the complete path to the kernel,
>>> instead of
>>> >>> simply "math."
>>> >>>
>>> >>> On Mac OS the path is:
>>> >>> /Applications/Mathematica.app/Contents/MacOS/MathKernel
>>> >>>
>>> >>> Regards,
>>> >>> Nate
>>> >>>
>>> >>> On Mon, Aug 9, 2010 at 4:13 AM, Cristobal Navarro <
>>> axischire at gmail.com>wrote:
>>> >>>
>>> >>>> hello,
>>> >>>>
>>> >>>> i am having problems launching remote kernels.
>>> >>>> i have a Xeon server (Linux) on which mathematica is installed, and
>>> >>>> the "math" command works.
>>> >>>>
>>> >>>> on my laptop, i have linux too, and on mathematica i add the kernel
>>> to
>>> >>>> be launched on the remote (the server)  node.
>>> >>>> then i try one example:
>>> >>>> 2+2
>>> >>>>
>>> >>>> i press shift+enter... mathematica asks me to insert the password of
>>> >>>> the remote node user name.... ok  and then i get error message:
>>> >>>>
>>> >>>> "The kernel serverKernel failed to connect to the front end. (Error
>>> =
>>> >>>> MLECONNECT). You should try running the kernel connection outside
>>> the
>>> >>>> front end."
>>> >>>>
>>> >>>> for debugging purposes, i made a kernel for my same laptop, just
>>> like
>>> >>>> a "Local" kernel but i choose remote and put my ip adress and my
>>> >>>> useracount of my laptop.
>>> >>>>
>>> >>>> i test 2+2, it asks my password..ok, then the same message:
>>> >>>>
>>> >>>> "The kernel self failed to connect to the front end. (Error =
>>> >>>> MLECONNECT). You should try running the kernel connection outside
>>> the
>>> >>>> front end."
>>> >>>>
>>> >>>> this is really weird.
>>> >>>>
>>> >>>> the parameters of the "self kernel" are this:
>>> >>>> `java` -jar `mathssh` fcluster@agua math -mathlink -LinkMode
>>> Connect -
>>> >>>> LinkProtocol TCPIP -LinkName "`linkname`" -LinkHost `ipaddress`
>>> >>>>
>>> >>>> if remote kernel does not work with my same computer, i better not
>>> >>>> keep trying with the server yet.
>>> >>>>
>>> >>>> any help is welcome, i really dont know what is going on.
>>> >>>>
>>> >>>> best regards
>>> >>>> Cristobal.
>>> >>>>
>>> >>>>
>>> >>>>
>>> >>>
>>> >>
>>> >
>>>
>>>
>>>
>>
>


  • Prev by Date: Re: remote kernel problem
  • Next by Date: MathWorld MapProjections
  • Previous by thread: Re: remote kernel problem
  • Next by thread: Compile with Boolean Arrays