Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2010

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Shift-Ctrl-N and Manipulate

  • To: mathgroup at smc.vnet.net
  • Subject: [mg114888] Re: Shift-Ctrl-N and Manipulate
  • From: Barak Shoshany <baraksh at gmail.com>
  • Date: Tue, 21 Dec 2010 00:21:17 -0500 (EST)
  • References: <201012191009.FAA04993@smc.vnet.net> <20101220152048.592555@jfultz3winlap>

Thanks for the quick reply!

Ctrl-Shift did not solve it, but Edit -> Preferences -> Evaluation -> Reset
to Defaults rechecked the box next to "Use only textual boxes when
converting input to typeset forms", which of course solved to problem. I
guess I might have unchecked it by mistake. Come to think of it, I should
have made the connection by myself just by reading the option's
description...

Best wishes,
Barak


On Mon, Dec 20, 2010 at 11:20 PM, John Fultz <jfultz at wolfram.com> wrote:

> This is not the behavior I see.  What I'm seeing is that the Input style
> leaves
> the following expressions (for example), alone when converted:
>
> Graphics[{Point[{1,1}]}]
> Manipulate[x,{x,0,1}]
> Slider[1]
>
> while the Output style causes them to convert to the graphics and
> interfaces.
> The critical option which is different between the Input and Output styles
> is
> the ShowStringCharacters option.  So, for example, this converts to a
> graphic...
>
> Cell["Graphics[{Point[{1,1}]}]","Input",ShowStringCharacters->False]
>
> while this one doesn't...
>
> Cell["Graphics[{Point[{1,1}]}]","Input"]
>
> (and yes, I didn't use the box forms for simplicity, but the same thing is
> true
> for the box forms)
>
> All of this is true for both v7 and v8, so I'm not at all certain that
> upgrading
> to v8 was the actual cause of this for you.  Instead, this suggests to me
> that
> you may have an option or stylesheet setting which is unwittingly
> contaminating
> the process.  I don't know how much you know about such things and whether
> you
> are likely to have deliberately or accidentally set one of these options.
>  An
> easy thing to do would be to reset the FE's preferences, which you can do
> by
> holding Ctrl+Shift while starting Mathematica (or Cmd+Shift on Mac).  If
> you
> have any custom settings for the front end, this will clean them out.  But
> the
> rogue setting might be specifically on a given notebook or on a stylesheet
> you've created, as well...there are too many possibilities to run down
> without
> getting some more information from you.
>
> Sincerely,
>
> John Fultz
> jfultz at wolfram.com
> User Interface Group
> Wolfram Research, Inc.
>
>
> On Sun, 19 Dec 2010 05:09:56 -0500 (EST), =D7'=D7=A8=D7=A7 =D7=A9=D7=95=
=D7=A9=D7 =D7=E2=84=A2 wrote:
> > Hi everyone,
> >
> > In previous versions of Mathematica, I could use the shortcut Shift-Ctr=
l-
> > N or the menu option Cell -> Convert To -> StandardForm to clean up and
> > format my code, for example, turn x^2 into a real superscript or x/y in=
to
> > a real fraction.
> >
> > However, after upgrading to Mathematica 8, this option also automatical=
ly
> > converts functions such as Manipulate or Slider into the actual output =
of
> > the function. The entire code I wrote for the Manipulate applet becomes
> > the actual applet, and so it's not possible to change the code any more=


  • Prev by Date: Re: Shift-Ctrl-N and Manipulate
  • Next by Date: Re: Mathematica daily WTF
  • Previous by thread: Shift-Ctrl-N and Manipulate
  • Next by thread: Re: Shift-Ctrl-N and Manipulate