Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2010

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Workbench fails to build documentation

  • To: mathgroup at smc.vnet.net
  • Subject: [mg110518] Re: Workbench fails to build documentation
  • From: Gerry Flanagan <flanagan at materials-sciences.com>
  • Date: Tue, 22 Jun 2010 07:01:29 -0400 (EDT)

I saw the line
> build/PathTest-HTML
>    
go by. I had problems with the "Create HTML" checkbox under Application 
Tools. I never researched further because unclicking the box gave me 
what I wanted.
Gerry F.


On 6/21/2010 2:12 AM, telefunkenvf14 wrote:
> On Jun 19, 6:46 am, "M.Roellig"<markus.roel... at googlemail.com>  wrote:
>    
>> Hi group,
>>
>> after some frustrating fights with Workbench 2 and quite unconclusive
>> emails with Wolfram Support I would like to ask if anybody else is
>> having similar problems or even any ideas how to solve them.
>>
>> The problem is: Workbench completely fails to build any documemntation
>> file. No matter which. I tried to use the example projects from the
>> Wolfram web pages. I used simple test cases. I even tried an fresh and
>> empty project
>> with an empty template page for a guides page. Everything else works
>> fine as far as I can tell. I can call the Mathematica kernel from
>> Workbench, I can debug code. I can run notebooks from within Workbench
>> as Mathematica and so on. It's just the building of documentation that
>> fails. I even reinistalled Workbench AND Mathematica. Wolfram support
>> has no clue what the problem might be and basically gave up which I
>> find somewhat unsupportive...
>> I created a test user to make sure that no umlauts in the user name/
>> path are messing things up.
>>
>> The building attempts produce the following messages in the cosole
>> window:
>>
>> --------------
>> BEGIN-----------------------------------------------------
>>
>> Buildfile: C:\Users\Test\WolframWorkspaces\Base\PathTest\docbuild.xml
>> clean:
>> main:
>> docbuild:
>>       [echo] DocumentationBuild: C:\Users\Test\.eclipse
>> \1678130227\configuration\org.eclipse.osgi\bundles\10\1\.cp
>> \MathematicaSource
>>       [echo] Mathematica Install Dir: C:\Program Files\Wolfram Research
>    
>> \Mathematica\7.0
>>       [echo] MathKernel: C:\Program Files\Wolfram Research\Mathematica
>    
>> \7.0\MathKernel.exe
>>       [echo] Input: C:\Users\Test\WolframWorkspaces\Base\PathTest/
>> PathTest/Documentation
>>       [echo] Output NB: C:\Users\Test\WolframWorkspaces\Base\PathTest/
>    
>> build/PathTest/Documentation
>>       [echo] Output Web: C:\Users\Test\WolframWorkspaces\Base\PathTest/
>    
>> build/PathTest-HTML
>> initMathematicaTask:
>> main:
>>       [echo] DOCUMENTATION BUILD
>>       [echo] Source: C:\Users\Test\WolframWorkspaces\Base\PathTest/
>> PathTest/Documentation
>>       [echo] Destination: C:\Users\Test\WolframWorkspaces\Base\PathTest/
>    
>> build/PathTest/Documentation
>>       [echo] Language: English
>>       [echo] Log path: C:\Users\Test\WolframWorkspaces\Base\PathTest/
>    
>> build/log/log.txt
>>       [echo] Exitcode path: C:\Users\Test\WolframWorkspaces\Base
>> \PathTest/build/log/exitcode.txt
>>       [echo] Application path: C:\Users\Test\.eclipse
>> \1678130227\configuration\org.eclipse.osgi\bundles\10\1\.cp
>> \MathematicaSource
>>       [echo] JLink path: C:\Program Files\Wolfram Research\Mathematica
>    
>> \7.0/SystemFiles/Links/JLink
>>       [echo] Build Index: True
>>       [echo] Link base: PathTest
>>       [echo] Script: C:\Users\Test\.eclipse\1678130227\configuration
>> \org.eclipse.osgi\bundles\10\1\.cp\MathematicaSource\DocumentationBuild
>> \SystemFiles\ant\Build\notebook.xml
>>
>> BUILD FAILED
>> C:\Users\Test\WolframWorkspaces\Base\PathTest\docbuild.xml:132: The
>> following error occurred while executing this line:
>> C:\Users\Test\WolframWorkspaces\Base\PathTest\docbuild.xml:97: The
>> following error occurred while executing this line:
>> C:\Users\Test\.eclipse\1678130227\configuration\org.eclipse.osgi
>> \bundles\10\1\.cp\MathematicaSource\DocumentationBuild\SystemFiles\ant
>> \Build\notebook.xml:71: Failed to launch or connect to Mathematica
>> kernel: Connected MathLink program has closed the link, but there
>> might still be data underway.
>>
>> Total time: 764 milliseconds
>>
>> --------------------------END ---------------------------------
>>
>>   I am using Windows 7 Enterprise 64 Bit.
>>
>> $Version
>>
>> "7.0 for Microsoft Windows (64-bit) (February 18, 2009)"
>>
>> Any ideas?
>>
>> Cheers,
>>
>> Markus
>>      
> If I had to guess...
>
> In Workbench, double-click on the PackletInfo.m file and then on the
> 'Documentation' tab (at the bottom of the screen). Now, highlight
> 'Guide' and create a new page (say, 'MyGuide'), and then highlight
> 'Tutorial' and create another new page (say, 'MyTutorial'. You don't
> actually have to fill these out yet.
>
> Select the 'MyGuide' page you've just created and hit the 'Set Main'
> button.
>
> Assuming you already have a bunch of functions with basic usage
> mesages defined in your package, when you expand the 'Symbols' folder,
> you should see a list of these functions. If they have a red X in
> front of them, then the function pages have not yet been created. One
> way to create a function page is to double click on one of these and
> follow the prompt. Mathematica will then open, and a new template will be
> generated for the function. You can then save and close it (or edit
> it, of course).
>
> Alternatively, you can create a bunch of these templates at once. To
> do so, click the 'Create Symbol Pages' button and choose the 'Select
> Missing' button. Mathematica will then iteratively build them all. Pretty
> slick, IMO.
>
> Make sure you're PackletInfo.m is saved and the build process *should*
> work now. :)
>
> Hope this helps... (I'm not a Workbench expert by any means)
>
> -RG
>
>
>    



  • Prev by Date: Re: Difficulty with saving Package .m files
  • Next by Date: Re: Lists: Row Vectors vs. Column Vectors. (feels like such a silly
  • Previous by thread: Re: Workbench fails to build documentation
  • Next by thread: Re: Workbench fails to build documentation