Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2010

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Interpolation undocumented error

  • To: mathgroup at smc.vnet.net
  • Subject: [mg113733] Re: Interpolation undocumented error
  • From: Oliver Ruebenkoenig <ruebenko at wolfram.com>
  • Date: Tue, 9 Nov 2010 03:54:36 -0500 (EST)

On Fri, 5 Nov 2010, Hyatt, John S wrote:

> Hi all,
>
> I have tried both the Obtuse and Imtek packages suggested.  They are installed and working correctly.  However, I cannot get a meaningful interpolation function to my data.  Using Imtek's imsUnstructuredInterpolation, I get the following error message:
>
> LinearSolve::luc: Result for LinearSolve of badly conditioned matrix {{-3.1356*10^21,-2.01921*10^21,-1.27651*10^21,-7.89872*10^20,-4.77313*10^20,-2.81064*10^20,<<40>>,-5.56912*10^18,-5.56912*10^18,-2.43624*10^18,-2.43624*10^18,<<315>>},<<49>>,<<315>>} may contain significant numerical errors. >>
>
> And for Obtuse, using the RBF method for Interpolation, I get:
>
> LinearSolve::luc: Result for LinearSolve of badly conditioned matrix {<<1>>} may contain significant numerical errors. >>
>
> Both of these messages are similar.  However, I don't know how to make 
> sense of this error either:  first, what is <<...>>, and second, what is

This means that not all data is displayed. The number inside tells you how 
many data the placeholder stands for.

> the message trying to say?  The data is single-valued and obviously lies

During the interpolation a matrix is build and that is found the be 
singular. Thus, the decomposition can not be made and no interpolation can 
be found.

> on a smooth surface - I can eyeball what a given value should be, but I 
> want a specific interpolation function so I can make it part of my 
> analysis routine.  Does anyone recognize this message, and for those of 
> you familiar with Obtuse and Imtek, has this problem cropped up before?

I am familiar with the IMS.

> As far as I can tell I'm setting up my data and interpolation in the 
> same 
> format as in the examples in both packages' documentation.  I am making

Without actually seeing the data it is difficult to say what the issue is. 
If you send me a notebook I can have a look)

> sure that the third element of each data point is the "z" value, and 
> that 
> the "x" and "y" designations are consistent within all the different 
> data 
> sets I'm trying to interpolate.  I've tried different orders of fitting 
> and different fit types, and each time, while I do get an interpolation 
> surface, it's complete nonsense (i.e. nowhere near
> t!
> he data).
>

Oliver

> Thanks in advance,
> John H
>
> ----- Original Message -----
> From: "Ingolf Dahl" <Ingolf.Dahl at physics.gu.se>
> To: mathgroup at smc.vnet.net
> Sent: Thursday, October 21, 2010 7:03:01 AM
> Subject: [mg113630] [mg113269] Re: Interpolation undocumented error
>
> You might try my "Obtuse" package, downloadable from http://www.familydahl. se/mathematica/ .
> This package was inspired by exactly this error message, and it contains five different interpolation methods, defined as "methods" to the Interpolation function. Which method to choose depends strongly on the character of the data, so you probably need to experiment a little to see what suits your case.
>
> Best regards
>
> Ingolf Dahl
> Ingolf.dahl at telia.com
>
> -----Ursprungligt meddelande-----
> Fr==E5n: Hyatt, John S [mailto:jshyatt at gatech.edu]
> Skickat: den 20 oktober 2010 10:06
> Till: mathgroup at smc.vnet.net
> ==C4mne: [mg113232] Interpolation undocumented error
>
> I am trying to use Interpolation to get an interpolation function of multidimensional data from light scattering.  I specifically want to be able to calculate the value of the function at any point within certain parameters. I have entered the data points as usual into Interpolation, but receive an error message:
>
> "Interpolation::indim: The coordinates do not lie on a structured tensor product grid."
>
> This error is undocumented in the Mathematica Help as far as I can tell, an
> d I don't know what the error means (i.e. what is a structured tensor produ=
> ==
> ct grid).  After searching the web for other people with the same issue, I =
> ==
> found only one thread on Wolfram's archives where the Imtek Mathematica Sup=
> ==
> plement was suggested as a fix and seemed to help the person.  However, the=
> ==
> IMS seems to be intended for use with an earlier version of Mathematica (I=
> ==
> have v7.0) and the installation instructions in any case aren't applicable=
> ==
> to this version.  Is there a fix for this in Mathematica, or does anyone k=
> ==
> now of any way to get the interpolation function I am looking for?  Would u=
> ==
> ninstalling Mathematica and installing version 6 followed by the IMS be the=
> ==
> only way to fix this?
>
> Thanks in advance for any help,
> John H
>
>


  • Prev by Date: Re: issue with LinearSolve[] when using SparseArray when
  • Next by Date: Re: issue with LinearSolve[] when using SparseArray when
  • Previous by thread: Re: Interpolation undocumented error
  • Next by thread: Strange diference in outputs!