Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2011

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Preventing In-line Math Typesetting From Being Scaled Down in Text Cells

  • To: mathgroup at smc.vnet.net
  • Subject: [mg120480] Re: Preventing In-line Math Typesetting From Being Scaled Down in Text Cells
  • From: John Fultz <jfultz at wolfram.com>
  • Date: Mon, 25 Jul 2011 07:28:45 -0400 (EDT)
  • Delivered-to: l-mathgroup@mail-archive0.wolfram.com
  • Reply-to: jfultz at wolfram.com

On Fri, 22 Jul 2011 19:46:07 -0400 (EDT), Gregory Lypny wrote:
> Hi everyone,
>
> When I include fractions as inline math typesetting, they are scaled down
> to fit the effective line height of the cell.  How can I prevent this or,
> I guess, make the line height automatically expand to accommodate the
> math?  If my regular text in the cell is 12-point times, I'd like all
> math variables that are not subscripts or superscripts to be 12-point as
> well.
>
> Incidentally, other big typeset objects like matrices are not scaled
> down, or at least they down't appear to be.
>
> Sincerely,
>
> Gregory

If you look in Core.nb, you'll find a style called "InlineCell".  This style is automatically applied to all inline cells everywhere.  One of the options it has set is:

ScriptLevel->1

This is what's causing the behavior you're seeing.  You can override this with a custom stylesheet.  For example, in a given notebook, you can make a private override by doing Format->Edit Stylesheet..., and pasting and interpreting the following cell expression at the end of the resulting stylesheet notebook:


Cell[StyleData["InlineCell"], ScriptLevel->0]


Sincerely,

John Fultz
jfultz at wolfram.com
User Interface Group
Wolfram Research, Inc.




  • Prev by Date: Re: CDF Files Break when being mailed or uploaded
  • Next by Date: Re: From Reduce to List
  • Previous by thread: Preventing In-line Math Typesetting From Being Scaled Down in Text Cells
  • Next by thread: Code is not working...