Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2011

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Problem displaying user-created .cdf files

  • To: mathgroup at smc.vnet.net
  • Subject: [mg123106] Re: Problem displaying user-created .cdf files
  • From: GARY PALMER <gpalmerlv at gmail.com>
  • Date: Wed, 23 Nov 2011 07:08:16 -0500 (EST)
  • Delivered-to: l-mathgroup@mail-archive0.wolfram.com
  • References: <CAMMfn1dHpvWkAMiev02LPF=8+TtsPu9RYnHoP5NYxddb_gKrHg@mail.gmail.com>

That was it. It's working fine now*. I think I started working on the
notebook with some functions and global variables in a package I named
AstroVectors`, and then realized that the cdf files might not work with the
package, so I removed the package load and put the functions and variables
in the notebook, but the context hung around.

It's useful to have the warning that there can be more than one context
with the same function, and you can't have too much security these days.

Thanks sticking with it.

Gary

* <http://faculty.unlv.edu/gbp/mma/rotate_on_arbit_axes.html>

On Tue, Nov 22, 2011 at 3:41 PM, John Fultz <jfultz at wolfram.com> wrote:

> Found the problem.  We have a security system which is, sometimes, a bit
> too
> paranoid.  One of the things that it excludes is symbols from unknown
> contexts.
>
> If you evaluate your input cells in a fresh, clean session of Mathematica,
> this
> won't be a problem.  But, it appears that's not what you did when creating
> this
> notebook.  Somehow, a number of symbols ended up in the AstroVectors`
> context.
> The ones I noted being in that context were:
>
> vFrame3D
> originC
> vLine
> xV
> yV
> zV
>
> If the Manipulate uses these symbols in the Global` context, then you
> shouldn't
> have any problem with the gray box anymore.
>
> Future versions of CDF Player/Mathematica will be more friendly about this
> sort
> of thing.  Hope this helps.
>
> Sincerely,
>
> John Fultz
> jfultz at wolfram.com
> User Interface Group
> Wolfram Research, Inc.
>
>
> On Mon, 21 Nov 2011 15:37:20 -0800, GARY PALMER wrote:
> > Sorry, I thought I posted it in a previous message. It is at
> > <http://faculty.unlv.edu/gbp/mma/rotate_on_arbit_axes.html>.
> > On Mon, Nov 21, 2011 at 2:41 PM, John Fultz <jfultz at wolfram.com> wrote:
> >
> >> If your web page is in a public place, I could look at it.
> >>
> > Sincerely,
> >
> > John Fultz
> > jfultz at wolfram.com
> > User Interface Group
> > Wolfram Research, Inc.
> >
> >>
> >> On Sun, 20 Nov 2011 23:45:16 -0800, GARY PALMER wrote:
> >> John,
> >>
> >> Thanks for the additional explanation.
> >>
> >>
> >> I doubt there was anything in my program that reset Enabled. I very
> >> possibly set it to False by accident while resetting Deployed. I'm
> >> getting a better understanding of the Option Inspector now, so perhaps I
> >> can avoid creating unnecessary problems.
> >>
> >>
> >> Everything is working well now in the notebook. It is in the web page
> >> that I am still having difficulties. My CDF file appears to load and
> >> shows the large star icon, but then comes up gray with the little star
> >> icon in the lower right corner. While it is loading a dialog flashes
> >> twice, but too quickly for me to read.
> >>
> >>
> >> Gary
> >>
> >> On Sun, Nov 20, 2011 at 5:00 PM, John Fultz <jfultz at wolfram.com> wrote:
> >>
> >>> The Deployed option, as you may have surmised, had absolutely nothing
> >>> to do with
> >> whether or not your sliders work.  And, in fact, Deployed has no impact
> >> on
> >> slider functionality at all.
> >>
> >> But sliders can be disabled by setting Enabled->False.  This is a useful
> >> feature, as it allows a continuous display of controls, but temporarily
> >> disabling them in cases where the controls are irrelevant.  This is
> >> quite
> >> common
> >> in user interfaces generally, and there's nothing strange about how
> >> Mathematica
> >> does it.
> >>
> >> What is strange is why you should have had to set Enabled->True
> >> explicitly.  To
> >> understand that, I'd have to see the code.  Enabled is set to True by
> >> default,
> >> and unless you've somehow changed the default settings, it should not be
> >> necessary to explicitly set it to True.
> >>
> >> In general, the Deployed option makes an output act more like an
> >> interface and
> >> less like a raw bit of output.  This means, for example,
> >>
> >> * Random bits of static text are not selectable or editable.  In most
> >> interfaces
> >> (imagine a dialog box in any program you used), you can't go about
> >> selecting
> >> bits of text and rewriting them unless that text is inside of a control
> >> like an
> >> input field.
> >>
> >> * Graphics are not editable.  You can't double-click to get inside them.
> >> You
> >> can't select them and resize them.  You can't take take 3D graphics and
> >> spin
> >> them around.  The graphics, like the text, are part of the background.
> >>
> >> * All controls remain active.  There are, in fact, other options you
> >> could have
> >> used to achieve the above effects, but those other options would have
> >> messed
> >> with the controls, as well.  By using Deployed->True (or the Deploy[]
> >> function,
> >> which basically sets Deployed->True), you get controls that work as they
> >> should
> >> while everything else remains a fully inert part of the background.
> >>
> >> Sincerely,
> >>
> >> John Fultz
> >> jfultz at wolfram.com
> >> User Interface Group
> >> Wolfram Research, Inc.
> >>
> >>
> >>> On Sun, 20 Nov 2011 05:34:52 -0500 (EST), Gary wrote:
> >>> Progress
> >>> I previously reported that the slider controls in my Manipulate[]
> >>> graphic were gray and inactive. Setting "Format --> Option Inspector -
> >>> -
> >>>> Cell Options --> General Properties --> Deployed --> True" did not
> >>> help (yes, the file was selected). But next to Deployed, I noticed
> >>> Enabled, so I set Deployed --> False and set Enabled --> True. That
> >>> turned on the blue slider buttons again. I rechecked by setting
> >>> Enabled --> False and resetting Deployed --> True. That produced
> >>> inactive slider buttons. Furthermore, in the main Cell menu, the
> >>> Delete All Output choice was now grayed out. I again set Deployed -->
> >>> False and set Enabled --> True and got the active controls back as
> >>> well as an active Delete All Output. So I did the obvious, setting
> >>> both Deployed and Enabled to True. The controls are active and Delete
> >>> All Output is active. The instructions I have found all said to set
> >>> Deployed --> True, but I con't recall any mention of Enabled. It is
> >>> not clear to me what Deployed --> True does in this situation. Enabled
> >>> --> True seems to be both necessary and sufficient, at least within
> >>> the notebook. Does Deployed affect only the cdf files?
> >>>
> >>> I am puzzled that my many searches for online documentation on this
> >>> point produced only snippets of information on Deployed (generally
> >>> with incomplete information on where to find it) and no information at
> >>> all on Cell Options --> General Properties --> Enabled (True/False).
> >>> For example, I don't find it here <http://reference.wolfram.com/
> >>> mathematica/ref/Manipulate.html>. I feel a need for a few collected
> >>> pages of expanded discussion of when and where the various options
> >>> available under the Options Inspector are or are not needed. There is
> >>> a great need for a document on trouble shooting. The technical
> >>> descriptions are not always obvious to a beginner. I am picking up a
> >>> few things, but at a cost which seems unnecessarily high. Some of the
> >>> needed discussion might be scattered among the many books on
> >>> Mathematica, or many of the answers might be concentrated in one or
> >>> two books, but which ones?
> >>>
> >>> Mathematica Home Edition 8, iMac, OS X 10.6.8, Chrome, Firefox
>
>


  • Prev by Date: Re: How to do quickest
  • Next by Date: Re: How to do quickest
  • Previous by thread: Re: Problem displaying user-created .cdf files
  • Next by thread: Help needed - Mathematica code