Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2012

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: CurrentImage Command not working in MacBook Pro

  • To: mathgroup at smc.vnet.net
  • Subject: [mg124649] Re: CurrentImage Command not working in MacBook Pro
  • From: George Woodrow III <georgevw3 at mac.com>
  • Date: Sat, 28 Jan 2012 06:36:31 -0500 (EST)
  • Delivered-to: l-mathgroup@mail-archive0.wolfram.com
  • References: <201201271113.GAA12531@smc.vnet.net>

I am using the same hardware (close enough, I think) and the same software. I did a quick check of both functions and they worked. They also worked fine on my 2011 MacBook Air.

I used to write code for OS X, but never had to dig that deeply into the system internals. You could try a system restore, perhaps??


george woodrow


On Jan 27, 2012, at 6:13 AM, Ruben wrote:

> Dear all,
> I'm using a mid 2009 MacBook Pro with OS X 10.7.2  and Mathematica
> 8.0.4 and unfortunately I'm having difficulties using the built-in
> camera with commands such as CurrentImage[] or ImageCapture[].
> The error messages that I get is the following:
> 
> LinkObject::linkn: Argument LinkObject[/Applications/Mathematica.app/
> SystemFiles/Converters/Binaries/MacOSX-x86/CameraCapture.exe,18,8] in
> LinkWrite[LinkObject[/Applications/Mathematica.app/SystemFiles/
> Converters/Binaries/MacOSX-x86/CameraCapture.exe,18,8],<<1>>] has an
> invalid LinkObject number; the link may be closed. >>
> 
> I also noticed that in the console there's a message saying:
> 
> Mathematica: CFURLCreateWithString was passed this invalid URL string:
> '/System/Library/CoreServices/CommonCocoaPanels.bundle' (a file system
> path instead of an URL string). The URL created will not work with
> most file URL functions. CFURLCreateWithFileSystemPath or
> CFURLCreateWithFileSystemPathRelativeToBase should be used instead.
> 
> I already contacted technical support but they told me it's not a
> Mathematica problem but a system problem so I'm wondering if there's
> someone who has experienced similar problems in the past.
> Any suggestions about how to fix this would be greatly appreciated.
> 
> Many thanks in advance,
> Ruben
> 
> 
> 




  • Prev by Date: Robust identifier for notebook objects?
  • Next by Date: Re Bezier curves mapped from 2D to 3D surface
  • Previous by thread: CurrentImage Command not working in MacBook Pro
  • Next by thread: NumberFieldClassNumber