Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2012

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Differential Equation: Not getting result

  • To: mathgroup at smc.vnet.net
  • Subject: [mg127336] Re: Differential Equation: Not getting result
  • From: Oliver Ruebenkoenig <ruebenko at wolfram.com>
  • Date: Wed, 18 Jul 2012 01:37:31 -0400 (EDT)
  • Delivered-to: l-mathgroup@mail-archive0.wolfram.com
  • Delivered-to: mathgroup-newout@smc.vnet.net
  • Delivered-to: mathgroup-newsend@smc.vnet.net
  • References: <20120717053145.BA8F96877@smc.vnet.net>


On Tue, 17 Jul 2012, Rahul Chakraborty wrote:

> Dear all,
>
> For the following code i'm not getting result. kindly tell me where i'm making mistake.
>
> Clear[x];
> r=1;
> K=1;
> eqn= (x^')[t]-r  x[t]  (1-x[t]/K)==0//Simplify;
> sol=NDSolve[{eqn,x[0]==1/2,x'[0]==0},x[t],{t,0,50}][[1]]
> ParametricPlot[Evaluate[{x[t]/.sol,D[x[t]/.sol,t]}],{t,0,50},Frame->True,AxesLabel->{"x",Overscript[x,"."]},AspectRatio->1]
> ParametricPlot[Evaluate[{t,x[t]/.sol}],{t,0,50},Frame->True,AxesLabel->{"t","x"},AspectRatio->1]
>
>
> Regards,
> rc
>
>


Hi,

you mean something like this?

Clear[x];
r = 1;
K = 1;
eqn = x[t]^2 - r x[t] (1 - x[t]/K) == 0 // Simplify;
sol = NDSolve[{eqn, x[0] == 1/2, x'[0] == 0}, x[t], {t, 0, 50}][[1]]

ParametricPlot[Evaluate[{x[t] /. sol, D[x[t] /. sol, t]}], {t, 0, 50},
   Frame -> True, AxesLabel -> {"x", Overscript[x, "."]},
  AspectRatio -> 1]
ParametricPlot[Evaluate[{t, x[t] /. sol}], {t, 0, 50}, Frame -> True,
  AxesLabel -> {"t", "x"}, AspectRatio -> 1]


Oliver



  • Prev by Date: Re: Differential Equation: Not getting result
  • Next by Date: Re: Sending an interrupt to the frontend?
  • Previous by thread: Re: Differential Equation: Not getting result
  • Next by thread: Re: Differential Equation: Not getting result