Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2012

[Date Index] [Thread Index] [Author Index]

Search the Archive

NonlinearModelFit properties are (suddenly) Missing[]

  • To: mathgroup at smc.vnet.net
  • Subject: [mg128597] NonlinearModelFit properties are (suddenly) Missing[]
  • From: Steven Roeters <sroeters at gmail.com>
  • Date: Thu, 8 Nov 2012 02:10:26 -0500 (EST)
  • Delivered-to: l-mathgroup@mail-archive0.wolfram.com
  • Delivered-to: l-mathgroup@wolfram.com
  • Delivered-to: mathgroup-newout@smc.vnet.net
  • Delivered-to: mathgroup-newsend@smc.vnet.net

Hello everyone,

I'm trying to fit a nonlinear spectroscopic response with a rather elaborate nonlinear model (so eleborate that posting the whole model here is not very insightful).

After performing numerous successful fits, I suddenly get an error if I try to evaluate the "Properties and diagnostics for parameter estimates". They are listed if I evaluate nlm["Properties"] (nlm being the name of fitted model), but when I evaluate them directly (e.g. nlm["ParameterTable"] ) I get "Missing[]" as a response. I can still access all the other properties.

The only thing that I changed was removing a fit parameter from the model and from the rest of notebook, which shouldn't be of any influence to this (I'd think). The fit also looks perfect, and I get no error message whatsoever while doing the fit.

Any help or ideas would be greatly appreciated!
Steven



  • Prev by Date: Re: Help with map /@
  • Next by Date: Re: Help with map /@
  • Previous by thread: Re: Quirks of EventHandler
  • Next by thread: Error Code: 616