MathGroup Archive 1998

[Date Index] [Thread Index] [Author Index]

Search the Archive

Time Series package w v 3.0

  • To: mathgroup at
  • Subject: [mg15166] Time Series package w v 3.0
  • From: "Atul Sharma" <mdsa at>
  • Date: Thu, 17 Dec 1998 00:27:45 -0500
  • Organization: McGill University Computing Centre
  • Sender: owner-wri-mathgroup at

I have been using the Time Series Analysis package with Mathematica 3.01
for some time. Usually, I am analyzing the spectrum of experimental
data, but today needed to analyze the spectrum of an AR model object
generated by the BurgEstimate routine.
I discovered that when I try to use the Spectrum command on a model
object, I get an
error that has to do with the ComplexToTrig function:

The output (using the example in the text) is

In: spc=Spectrum[ARModel[{1,-0.5},1],w]

1/(2 Pi ) ((  TimeSeries`TimeSeries`Private`ComplexToTrig[
      1\/\(\(2.25`\[InvisibleSpace]\) - 1.5`\ E\^\(\(-I\)\ w\) -
          1.5`\ E\^\(I\ w\) + 0.5`\ E\^\(\(-2\)\ I\ w\) +
          0.5`\ E\^\(2\ I\ w\)\)])\)\)\)

I recall that when I bought the package, I had to comment out the
Needs[] for a Algebra`Trigonometry`, which loaded  the ComplexToTrig
function. I assumed this was a holdover from v 2.0 which had become a
kernel function (ExpToTrig). The package worked fine until I tried to
analyze a model object, as noted above. In the definition of the
Spectrum[ ], I replaced the call to ComplexToTrig with ExpToTrig
without any luck, and also modified Expand to TrigExpand, but these
changes kill the function. Any ideas would be greatly appreciated.

A. Sharma

  • Prev by Date: RE: Disabling a button during the computation??
  • Next by Date: Re: Making Change
  • Previous by thread: Re: Mathematica <-> Java???
  • Next by thread: Re: Time Series package w v 3.0