MathGroup Archive 1998

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Time Series package w v 3.0

  • To: mathgroup at
  • Subject: [mg15184] Re: Time Series package w v 3.0
  • From: default < at>
  • Date: Fri, 18 Dec 1998 02:11:00 -0500
  • Organization: Raytheon Company
  • References: <75a4h7$>
  • Sender: owner-wri-mathgroup at

On the FAQ page

the following description of your problem appears (and according to it
you perhaps still need to make one more change from ComplexToTrig to
in the code)

Why do I get TrigExpand::obslt and Needs::nocont errors while loading

When you load TimeSeries under Mathematica 3.0, you will see the
following error messages

In[1]:= Needs["TimeSeries`TimeSeries`"]

   Trigonometric manipulation functions TrigExpand, TrigFactor,
    TrigFactorList and TrigReduce are now autoloaded.  TrigToComplex
    and ComplexToTrig have been renamed TrigToExp and ExpToTrig and are
    also now autoloaded.  The package Algebra`Trigonometry` is

   Context Algebra`Trigonometry`
     was not created when Needs was evaluated.

These error messages are generated because TimeSeries attempts to load
the package Algebra`Trigonometry`. The functionality of this package
has been incorporated into the Mathematica kernel. Additionally, the
command ComplexToTrig has been renamed to ExpToTrig. There are two ways
to workaround this problem.

First, you can define the function

    ComplexToTrig[qq_] := ExpToTrig[qq]

and ignore the warning messages.

Second, you can edit the TimeSeries.m file. Delete the reference to
Algebra`Trigonometry` in the BeginPackage statement, and rename the two
instances of ComplexToTrig to ExpToTrig.

Atul Sharma wrote:

> I have been using the Time Series Analysis package with Mathematica 3.01
> for some time. Usually, I am analyzing the spectrum of experimental
> data, but today needed to analyze the spectrum of an AR model object
> generated by the BurgEstimate routine.
> I discovered that when I try to use the Spectrum command on a model
> object, I get an
> error that has to do with the ComplexToTrig function:
> The output (using the example in the text) is
> In: spc=Spectrum[ARModel[{1,-0.5},1],w]
> Out[122]=
> 1/(2 Pi ) ((  TimeSeries`TimeSeries`Private`ComplexToTrig[
>       1\/\(\(2.25`\[InvisibleSpace]\) - 1.5`\ E\^\(\(-I\)\ w\) -
>           1.5`\ E\^\(I\ w\) + 0.5`\ E\^\(\(-2\)\ I\ w\) +
>           0.5`\ E\^\(2\ I\ w\)\)])\)\)\)
> I recall that when I bought the package, I had to comment out the
> Needs[] for a Algebra`Trigonometry`, which loaded  the ComplexToTrig
> function. I assumed this was a holdover from v 2.0 which had become a
> kernel function (ExpToTrig). The package worked fine until I tried to
> analyze a model object, as noted above. In the definition of the
> Spectrum[ ], I replaced the call to ComplexToTrig with ExpToTrig
> without any luck, and also modified Expand to TrigExpand, but these
> changes kill the function. Any ideas would be greatly appreciated.
> A. Sharma

  • Prev by Date: Re: combinatorics
  • Next by Date: Re: Reversing the axis of a plot
  • Previous by thread: Time Series package w v 3.0
  • Next by thread: combinatorics