MathGroup Archive 1998

[Date Index] [Thread Index] [Author Index]

Search the Archive

MathLink with Win95

Hi, folks.  I have downloaded what I believe to be the latest MathLink 
SDK from Wolfram Research.  I've been able to compile and run the first
test program, addtwo, but it doesn't seem to work.

The release notes I got with the SDK are for Win 3.1, I'm using Win95
with Visual C++ 5.0

To compile addtwo, I ran mprep to generate addtwotm.c, then created a
Vis C++ project containing addtwo.c, addtwotm.c, and the necessary
mathlink libs.

I've copied the appropriate DLLs into the WINDOWS\SYSTEM directory.

When I run addtwo without any arguments, I'm prompted for  "LISTEN ON"
and "CONNECT TO".  When I run it with the arguments given in the
Release Notes:

C:\mathlink\samples\addtwo -linkmode listen -linkname "first try"

it returns to the command shell immediately.

I follow this with:
link = Install["first try", LinkMode->Connect]

and I get:
    "\!\(LinkObject[\(\"first try\", 3, 2\)]\) is dead; attempt to
connect \ failed."

My guess is that the service supposedly created by running addtwo from
the command link isn't created; stepping into the program while running
it seems to show that when something is typed into the "Listen to"
window, the call returns zero, and the program ends.

Anybody have advice on using Win95/Visual c++ for building mathlink
programs that work?  Thanks.

Email:    David Konerding     WWW:
Snail: Graduate Group in Biophysics
Medical Sciences 926, Box 0446
University of California
San Francisco, CA 94143

  • Prev by Date: Simple algebra problem
  • Next by Date: Re: Making multiple plots
  • Prev by thread: Re: Simple algebra problem
  • Next by thread: Re: MathLink with Win95