MathGroup Archive 1998

[Date Index] [Thread Index] [Author Index]

Search the Archive

MathLink and Redhat 5.0

I am trying to port a working Mathlink module from Windows NT 4.0 SP3 to
RedhatLinux5.0.  Once the module compiled I tried to launch it from a
shell and it immediately core-dumped.  So I went back to the prebuilt
Mathlink eanmple:
and ran it in a shell.  Everything worked fine, I was able to link with
a notebook
and use the function AddTwo.  Then I tried to build the examples in:
I changed to that directory and ran 'make' to generate the executable:

When I attempted to run this executable from a shell I got an immediate

I next tried the same thing on a machine running RedHat 4.2 (i.e.
rebuild addtwo and
run it from a shell).  It works fine!

It seems, therefore, that the problem is the result of a change between
and Redhat5.0.  Perhaps the change from using libc to glibc? 

Has anybody else encountered this problem?  Any suggestions will be
welcome.  Until I can get the examples to work I'm stuck on my original

  • Prev by Date: How to draw an ellipse?
  • Next by Date: Re: Assuming n is even
  • Prev by thread: RE: How to draw an ellipse?
  • Next by thread: Need help with an error message...