MathGroup Archive 2000

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Unix Sound Problems

  • To: mathgroup at
  • Subject: [mg24229] Re: Unix Sound Problems
  • From: adam_smith at
  • Date: Sat, 1 Jul 2000 03:22:01 -0400 (EDT)
  • References: <8j9dmo$> <> <8jc6tb$>
  • Sender: owner-wri-mathgroup at


Thanks for the tip.

I tried implementing the sound.m files as outlined on the Wolfram
support web site, but it did not work.  The "sound" window would pop
up, but then nothing happened.  The kernel just kept chewing away at
it.  I did notice the the sound menu in the window was "grayed out".
My system came preinstalled with Red Hat Linux 6.0, so I do not know if
something was left out of the installation that motifps needs.  If
anyone has any ideas on the fix, please let me know.  I am new to Linux
and have no idea what to look at to try and fix it.

However the procedure below worked beatuifully if I changed the Run
command to "esdplay".  Just thought others might like to know.

Adam Smith

In article <8jc6tb$de3 at>,
  "P.J. Hinton" <paulh at> wrote:
> On Tue, 27 Jun 2000, P.J. Hinton wrote:
> This is a correction to this code snippet in my prior posting:
> > mySound[snd_Sound] :=
> >   Module[
> >     {tmpnam = Close[OpenTemporary[]]},
> >     Export[tmpnam, sound, "WAV"];
> >     Run["/usr/bin/mme/decsound -play", tmpnam];
> >     DeleteFile[tmpnam];
> >     Return[snd]
> >   ]
> The second argument to export should be snd, not sound.
> mySound[snd_Sound] :=
>   Module[
>     {tmpnam = Close[OpenTemporary[]]},
>     Export[tmpnam, snd, "WAV"];
>     Run["/usr/bin/mme/decsound -play", tmpnam];
>     DeleteFile[tmpnam];
>     Return[snd]
>   ]
> I apologize for the confusion.
> --
> P.J. Hinton
> Mathematica Programming Group           paulh at
> Wolfram Research, Inc.

Sent via
Before you buy.

  • Prev by Date: Re: making a plane
  • Next by Date: Evaluate and HoldAll
  • Previous by thread: Re: PrimeQ queries
  • Next by thread: Evaluate and HoldAll